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Introduction To ReviewPlus

ReviewPlus is a general-purpose plotting tool, capable of displaying interactive 2D and 3D graphs of raw,
analyzed, and simulation data. It can mix and couple 2D and 3D plots in one display, providing a rapid
means of examining 3D data. ReviewPlus displays data retrieved from PTDATA and MDSplus systems,
and can make use of the Internet to display data from any fusion research site with an MDSplus data
server. In addition, ReviewPlus supports User Written IDL Data Procedures and Post Draw IDL
Procedures, making it a powerful and versatile visualization tool.

About This User Manual

This User Manual was written for new users of ReviewPlus. It will explain the functions found in the
program and will get you started using the program to plot signal and point data. The manual can help
you learn a few of the more advanced plotting techniques available with ReviewPlus and may also serve
as a quick reference for ReviewPlus functions, once you've mastered the program. The User Manual
assumes you have a good understanding of physics, engineering, and the data signals generated by
fusion research facilities. Attempting to explain the nature of the data signals, and how to develop more
meaningful data through analysis of those signals, is beyond the scope of this manual.
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Document Conventions

While using this User Manual, you will see that certain words or phrases are represented in different fonts
or typefaces. Different words are represented in the same style to indicate that they belong to a specific
category.

The types of categories that are represented this way include:

• Application
o Example: Start ReviewPlus.

• Application Window
o Example: This opens the ReviewPlus Setup dialog.

• Menu>Command
o Example: Use Edit>Set Signals to enter signal expressions.

• GUI text
o Example: Enter shots under LIST OF SHOTS TO PLOT.

• user input text
o Example: In the List of Shots field, type 104276.

• computer output text
o Example: The command will return kill -ReviewPlus: not a valid command

switch

• filename
o Example: Open the example file review_example.revplus.

• [keyboard entry]
o Example: Type your name, then press [Enter].

• [key]+[combination]
o Example: Press [Ctrl]+[Alt]+[Del] to log in.

• User Manual Section
o Example: For more information on signals, refer to Defining Signals and Retrieving Data.
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Mouse Definitions

The following is a description of the actions needed to accomplish certain mouse related tasks.
Remember, Mouse refers to the actual input device you move with your hand, and Cursor refers to the
mouse pointer that moves about on your display screen as you move the Mouse.

• Click: Click the left mouse button once on an item or button and then release it.

• Double-click: Click the left mouse button twice rapidly and then release it.

• Right-click: Click the right mouse button and release it.

• Select: Click the left mouse button on the item and then release it.

• Drag: Click and hold the left mouse button and then move the mouse.

• Drop: Move the mouse cursor so that it hovers over an item on the screen; click and hold the left
mouse button, then move the mouse so that the item being moved appears to cover or hover
over the target item on the screen; release the mouse button.

• Scroll: Use the scrollbar found at the side or bottom of a list window to move within the list.
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Quick-Start Guide To ReviewPlus

This Quick-Start Guide assumes that ReviewPlus has been installed on your system and that you're
already familiar with most of the terms used. It also assumes you know how to navigate within your
system and find ReviewPlus, how to start and quit the program, and how to open and save files.

Plotting a Signal

Start ReviewPlus. The application window that opens on your screen is referred to hereafter as the 'main
display window'. This window displays the plots generated by ReviewPlus. The application menu bar
holds four menu command lists: File, Edit, Transform, and Help.

Click Edit>Set Signals. This launches the ReviewPlus Setup dialog.

The table found in this dialog is used to enter signal expressions for plotting and will be your main
interface into ReviewPlus. Move your cursor to the first open cell in the Z Data Signal column and left-
click, making the cell active. A cell must always be active in order to accept a signal name.

Type the signal name IP (for Plasma Current) and press [Enter] on the keyboard. Then, click the Apply
button near the bottom of the Setup dialog. ReviewPlus plots the signal in a plot box in the main display
window.

For more information on signals, see Defining Signals and Retrieving Data.

Selecting a Shot Number

Note that if there are no shot numbers entered in ReviewPlus, the signal data displayed is always from
the most recently completed shot (and this shot will change during experiment operations). To retrieve
signal data for a particular shot, type the shot number (for example, 104276) in the Default Shot field
near the bottom of the main display window and click Update. The Setup dialog also contains controls
for entering shot numbers.

For more information on shot numbers, see Defining Shot Numbers.

Modifying a Plot

Click Select near the top of the main display window. Now, click and select the IP signal trace in the
plot box. Once the signal trace is selected, the Transform menu commands are enabled. Click
Transform>Derivative to see an example of a transform in action. In this case, the time derivative of IP
is shown in the next plot. Now, click the Mouse Mode - Zoom, and then move the cursor into the plot
window, click and hold the left mouse button and drag the cursor sideways for a short distance within the
plot. When you release the mouse button, the plot changes to mirror the range of data you 'selected' while
dragging the mouse. Now, click the right mouse button within the plot to reveal a list of commands that
can be performed on the signal or the plot. Choose the Set Appearance command, and then click the
COLOR drop-down list in the Set Appearance dialog and choose blue. This action changes the color of
the selected signal trace and legend.

These are some simple examples of what you can do with ReviewPlus. For more information on
modifying signals and plots, see Interacting with Plots and Customizing the Appearance of Plots.
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ReviewPlus also features a REVIEW mode command line interface, the ability to invoke user written data
procedures and post draw procedures, and the ability to retrieve data from MDSplus servers at remote
facilities. For more information on these capabilities, see Advanced Plotting Techniques and the Tutorials.

Help is always available in ReviewPlus by selecting the menu command Help>Getting Started, or
Help>Printing.
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Tour of the User Interface

The Main Display Window

Figure 1: Main Display Window – Launched by starting ReviewPlus

1. The four major menus of commands are available here: File, Edit, Transform, and Help.
2. Mouse functionality can be selected and changed using the Mouse Mode controls.
3. All of the plots created by ReviewPlus will be displayed here, along with their axis units,

legends, and other annotations.
4. The Status area displays messages when the program is performing certain functions.
5. The Default Shot area provides an easy way to enter shot numbers and to monitor the most

recent shots.

* Clicking the Right Mouse Button in a plot window reveals a list of commonly used commands.
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The Plot Display Window

Figure 2: Plot Display Window

There are 4 plot boxes displayed above each containing one data trace that use various plot types
and signal symbols. The naming conventions are described below and refer to the lower-left plot box:

• The Plot Title is "Thomson Scattering Profile"
• The Legend is "Te at t = 3000 ms"
• The X axis scale is "Channel"
• The Z axis scale is "Temperature (eV)"

Controls for these parameters are available using Edit>Set Appearance. See Customizing the
Appearance of Plots for more information.
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The Restore a ReviewPlus File Dialog

Figure 3: Restore a ReviewPlus File Dialog - Launched with File>Restore

1. Use Path and Filter at the top to type directory and file names and filter
files.

2. Use the Path and File windows to interactively navigate within the file
system.

3. Use File to type a specific file pathname.
4. Use Restore Shots and Retrieve Data to determine how ReviewPlus

loads saved data.
5. Dismiss closes the dialog.
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The Print Dialog

Figure 4: Printing Dialog - Launched with File>Print Setup

1. Use the upper controls to determine where and how your plots are
printed.

2. Use the lower controls to specify properties for your print jobs.
3. Print or Cancel your job or get Help printing with the click of a button.
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The Setup Dialog

Figure 5: Setup Dialog - Launched with Edit>Set Signals

1. Use the Signal Table to enter signal expressions and other modifiers for retrieving signal
data and displaying plots.

2. Modify the signal table list using the controls below the table.
3. Use the controls in LIST OF SHOTS TO PLOT to create lists or ranges of shots or query a

relational database for shots based on their global properties.
4. Apply changes to your plots, refresh the signal data, or clear the table using the buttons at

the bottom of the dialog.
5. Open the Menu of signals and pointnames (also referred to as the Signal Menu).
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The ReviewPlus Signal Menu

Figure 6: ReviewPlus Signal Menu - Launched with Edit>Set Signals>Menu of signals and pointnames (button)

1. Use this dialog to choose from a list of signals and pointnames.
2. Query the database for a list of use signals matching your criteria (if your

system supports this feature).
3. Create a Custom Query to peruse the database.
4. Get help with a particular signal or pointname.
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The Set Appearance Dialog

Figure 7: Set Appearance Dialog - Launched with Edit>Set Appearance or RMB>Set Appearance*

Use these controls to:

1. Select a specific plot.
2. Change the plot type.
3. Configure a plot's properties.
4. Select a specific signal within a plot.
5. Alter a plot's appearance.
6. Apply the current settings and get help.

*RMB = Right Mouse Button
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The Preferences Dialog

Figure 8: Preferences Dialog - Launched with Edit>Preferences

Use the ReviewPlus Preferences dialog to:

1. Set the search paths for User Written Data Procedures and Post Draw
Procedures.

2. Set the path for legacy data files.
3. Set program defaults.
4. Set display defaults.
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Defining Signals and Retrieving Data

As stated in the Introduction, ReviewPlus is a general-purpose plotting tool, capable of displaying
interactive 2D and 3D graphs of raw, analyzed, and simulation data. There are two main identifiers of the
data displayed by ReviewPlus: the shot and the signal. The shot number refers to a specific fusion
experiment from which data will be retrieved. The signal refers to the specific data retrieved from that
experiment. This section details how ReviewPlus handles signals and signal data.

Signal Expressions

Signal data is retrieved from the PTDATA or MDSplus data storage systems at your facility. Signal data
can also be retrieved over the Internet from remote MDSplus data servers. A signal 'expression' is a
description of the specific signal data (along with any modifiers) that is entered in ReviewPlus and used
to retrieve and display data. Signal expressions can take a variety of forms.

A signal expression can refer to:

• 2D signals plotted against their natural dimension, such as temperature versus time
• 3D signals plotted versus both or either natural dimension, such as temperature versus time and

position
• data combinations, such as ABS(IP) or PTOT*PTAUE
• user-written IDL data procedures

When a signal is plotted against its natural dimension, the dependent data (the data being measured) is
plotted along the Z axis, and the independent parameter (such as time) is plotted along the X axis. All
signals plotted by ReviewPlus are assumed to have a Z axis parameter and are plotted versus the X axis
by default.

2D or 3D signals are plotted with the dependent data again on the Z axis, and the independent
parameters are plotted on the X and Y axes. X always refers to the first dimension of the signal and Y (if
used) refers to the second dimension. Please note that ReviewPlus does NOT make the assumption that
the X dimension is always time. Profiles are stored in MDSplus in many different ways, such that their first
dimension will not, in general, be time. This is in contrast to 2D data from the DIII-D PTDATA system,
which nearly always has time as its lone dimension.

Data combinations are mathematical combinations of signals. In an expression like:

WMHD / (PINJ + POH - WDOT)

the four signals in the expression may be on different timebases. In order to perform a mathematical
operation using the signals, ReviewPlus uses this method for determining a common timebase:

• ReviewPlus determines the greatest lower bound and the least upper bound of the individual
signals' timebases:

tmin = MAX( MIN(t0), MIN(t1), MIN(t2),...)
and

tmax = MIN( MAX(t0), MAX(t1), MAX(t2),...)

• It then takes the maximum number of samples of the individual signals' timebases (call this "nt")
• It constructs a new timebase from tmin to tmax in nt equal steps
• It then interpolates all the individual signals onto this new timebase and evaluates the

mathematical formula using IDL's expression evaluator (the EXECUTE() function)
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It is, therefore, important that all the signals in the data combination have the same physical dimension
(usually time or position). Since ReviewPlus uses IDL's expression evaluator, any valid IDL math
operation is allowed, subject to the rules of IDL programming.

For more information, see the IDL Manuals. User-written IDL data procedures are described in Advanced
Plotting Techniques and Tutorial 3.

Evaluating a Signal Expression

All signal expressions ultimately refer to data signals from PTDATA or MDSplus, or from IDL functions.
Unless you specifically indicate that the expression is from MDSplus, ReviewPlus uses the following
algorithm to determine the ultimate location of the data requested (Figure 9).

Figure 9: Algorithm

Entering a Signal Expression in ReviewPlus

Signal expressions are entered in ReviewPlus by selecting the menu command Edit>Set Signals,
clicking in a cell in the Z Data Signal column of the ReviewPlus Signal table and typing the expression,
then pressing [Enter].
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The Status column of the Signal table will display an OK if the data has been retrieved successfully and
will be blank if the data has not yet been retrieved. The word ERROR will be displayed if there is a
problem retrieving signal data or plotting an expression. When it appears, click on the word ERROR for
more information about the problem.

The ReviewPlus Signal Table

The ReviewPlus Signal table can be used to build lists of signal expressions for storage and later
retrieval. By typing signal expressions and pressing [Enter], you can enter expressions in the table just as
in a spreadsheet. Once a list is built, it can be saved using the menu command File>Save As. (See File
Operations for more information.)

Signal expressions can be manipulated within the Signal table using the buttons below the table.

• To alter the appearance of a signal plot, use the Set Appearance button. (See Interacting with
Plots and Customizing the Appearance of Plots for more information.)

• To delete a signal expression from the table, use the Delete button.
• To create an empty row below the row where the cursor is placed, use Insert.
• To copy the signal expression in a row where the cursor is placed to a new row just below it, use

Copy.
• To move a signal expression from one row to another, use the Move button.
• To re-retrieve the data for a signal expression from its source and re-plot it, use Refresh.
• The Expand Cell button is used when text overruns a cell. When this button is clicked, a dialog is

displayed that contains the entire text of the cell inhabited by the cursor. If the text in the cell is
editable, then the text in the dialog is also editable.

Additionally, the buttons at the bottom of the ReviewPlus Setup dialog can also affect the signal
expressions and plots.

• The Done button applies the current settings in the Setup dialog to all plots, and then dismisses
the dialog.

• The Apply button applies the current settings in the Setup dialog to all plots.
o Note: If you type an entry into a new row, you need to use the Apply button. If there is

already an entry in that row that has been retrieved once (if there is an entry in the status
column) and you make a change and move the cursor out of the cell, the change will be
applied immediately. If you don't want the changes applied immediately, you can change
this setting using Edit>Preferences. (The general rule is if the Apply button is lit, you
should use it.)

• The Refresh All button retrieves the data for all signal expressions and shots currently entered in
ReviewPlus and re-plots them. The menu command Edit>Refresh All Signals also re-retrieves
the signal data for all plots currently displayed by ReviewPlus.

• The Clear button removes all signal expressions from the Signal table and clears the main
display window. You can also select the menu command Edit>Clear All Settings to achieve
the same effect.

• The Menu of Signals and Pointnames is described at the end of this section.

Plotting One Signal vs. Another

One signal can be plotted versus another by entering the second signal expression in the X or Y Data
Signal column of the Signal table. There must be a signal expression in the Z Data Signal column of the
Signal table for this feature to work.
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Here's how ReviewPlus handles the case where the Z signal and the X/Y signal have dimensions of
different sizes. This algorithm depends on whether the Z signal is a 2D signal (data versus one other
dimension) or a 3D signal (data versus two other dimensions).

For a 2D signal (ZvsX), ReviewPlus interpolates the X expression onto the Z expression's natural
dimension. The Z and X signals must therefore have commensurate dimensions. For example, if the Z
signal is WMHD, whose natural dimension is time, the X signal must also have a natural dimension of time.
So, it is legal to plot WMHD versus IP, since both signals are individually measured versus time.

For a 3D signal, the signal specified under X or Y Data Signal in the Signal table must correspond to
one of the two dimensions of the Z Data Signal expression. This means that it must have the same
number of elements as one of the 2 dimensions. For example, if the Z signal is a 1000 x 300 matrix, the
X/Y signal must be a vector with either 1000 or 300 elements. If the X/Y signal has 1000 elements,
ReviewPlus assumes that it is to be used as the X dimension of the signal; whereas, if the X/Y signal has
300 elements, it is assumed to be the Y dimension of the signal. No interpolation is allowed, so the X/Y
signal must be directly commensurate with the Z signal.

Overplotting Signals

When only one signal expression is entered in the Signal table, and the signal data is retrieved for
multiple shot numbers, ReviewPlus will display the resultant signal traces in a single plot box. In general,
each Signal table row entry will have one data trace plotted for each shot, so one row may have multiple
traces associated with it.

When signal expressions are entered on separate rows of the Signal table, they can be overplotted
(displayed in one plot box) by altering the setting in the Box column of the Signal table. By default, each
signal expression entered in the Signal table has the value in the Box column set to New, meaning they
will be plotted in 'New' or separate plot boxes. When you click in the Box cell and remove the setting, the
signal is overplotted on the closest signal above it in the Signal table. Many signals can be overplotted
this way, but be aware that ReviewPlus will overplot signals that do not share common units of measure
for their axes.

Customizing Signal Data Retrieval

The ReviewPlus Signal table can be used to customize the retrieval of signal data by defining settings in
the columns described below.

• Server

Signal data can be retrieved from different MDSplus servers at locations around the world,
provided that access to the data has been made available via the Internet. You can view
remote data by entering the MDSplus server IP address (for example, atlas.gat.com for
General Atomics) in the Server column. Remember that other MDSplus data servers may
use different naming conventions for their shots and signals.

See Defining Shot Numbers and Tutorial 1 for more information.

• Tree

If you are familiar with MDSplus, and would like ReviewPlus to retrieve your signal
expression directly from an MDSplus tree, enter the tree name in the column marked Tree. If
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you do not specify an MDSplus tree, ReviewPlus uses the algorithm shown in Figure 9 to
determine how to evaluate your signal expression.

• tmin and tmax

The tmin and tmax columns of the Signal table allow you to enter minimum and maximum
time ranges and retrieve only a subset of data for a signal. The tmax entry must be greater
than the tmin entry for these settings to be applied. You can also set ranges for individual
signals and plots using Configure: Ranges in the Set Appearance dialog.

For more information on setting ranges, see Configuring Plot Ranges.

• ICAL

When dealing with the PTDATA system, the default value for the ICAL column is set to 1. If
you change it to a different value, the data you request comes back in a different form:

ICAL Data Units returned

0 digitizer counts

1 physics units (default, most often used)

2 volts input to the digitizer

3 voltage at the integrator output

4 returns the integrated signal in v-sec

10-14 same as 0-4 except for the baseline algorithm

20 returns data in the original integer format as provided by
PTDATA

Note that the ICAL value only applies to signals retrieved from PTDATA. It is ignored for any
other signal.

• Units of Measure

The units of measure of a plotted signal trace are displayed in the Z units, X units, and Y
units column of the Signal table. Note that ReviewPlus treats axis units of measure as
labels only, and it associates the axes of signals in separate plots that share a common unit
of measure.

Signals whose axes share units of measure, but whose units refer to different qualities, can
be separated by assigning an arbitrary unit of measure to the axis of one of the signals. This
capability serves to differentiate units of measure into "physical units" (those that refer to real-
world signal measurement units) and "logical units" (those used by ReviewPlus to associate
separate plot axes for functions like Crosshairs and Slicing). By default, the logical units are
the physical units, but you can override this when necessary by changing the logical unit label
using the Set X Units or Set Y Units columns of the Signal table.

For example, if two signals have "m" (meters) as their Y-axis physical units of
measure, but one signal measures major radius and the other measures minor
radius, the logical Y units of the second signal can be arbitrarily changed using Set Y
Units to keep ReviewPlus from linking the two axes during plotting. Be aware that
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changing logical units of measure using Set X Units or Set Y Units will not transform
the signal trace itself (for example, entering cm for a signal whose physical units are
m will not multiply the data by 100).

See Units of Measure - In Depth and Tutorial 2 for examples of this process.

• Post Draw Procedures

ReviewPlus allows Post Draw Procedures to be performed on signal data prior to plotting. A
Post Draw Procedure is a user written IDL procedure that modifies retrieved signal data and
plots it in the main display window. The procedures are stored on the user's system, and
are called by entering the procedure name in the Post Draw Procedure column in the
Signal table.

See Advanced Plotting Techniques and Tutorial 3 for more information.

The Signal Menu

If your site maintains a signal documentation scheme in a relational database, ReviewPlus can use it to
present a menu of available signals. This menu can be accessed using the Menu of signals and
pointnames button in the Setup dialog. You can select a signal from the menu and enter it in the Signal
table by clicking inside a cell in the Z Data Signal column in the Signal table, which makes the cell active,
and then clicking on a signal number in the Signal Menu. This loads the signal in the Signal table. When
you click the Apply button at the bottom of the Setup dialog, the signal plot appears in the main display
window.

The Signal Menu has columns for the Units of Measure, a short description of the signal, where the
signal resides in the data system, etcetera. (Note that the Units of Measure may not always be strictly
correct, refer to the data.) Clicking on a column heading will sort the table by the contents of that column.

The Signal Menu also contains a simple query constructor to filter the list of signals. Choose the names
of columns and operators from drop-down lists to specify values to filter the list. The Show Query button
displays the query being sent to the relational database. Custom Query allows display to all columns in
the table and provides a window in which to type an SQL query.

There is a button near the bottom of the Signal Menu that can provide help on a particular signal. Click
the button, and then click on a signal name in the list. This activates your web browser and opens a web
page that displays documentation on the selected signal.
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Defining Shot Numbers

As stated earlier, a shot number refers to a specific experiment from which data will be retrieved, and a
signal refers to the specific data retrieved from that experiment. This section describes how shot numbers
are used in ReviewPlus.

Entering Shot Numbers in ReviewPlus

There are three main areas used to enter shot numbers in ReviewPlus:

• Default Shot text field at the bottom of the main display window
• Setup dialog under the sentence "LIST OF SHOTS TO PLOT”
• Signal table in the column labeled "Shot"

Note that in any of these places, if the field where the shot number should be entered is left blank, its
value is assumed to be zero.

The Simplest Way to Enter Shot Numbers

The easiest way to retrieve and plot data for one shot is to enter the shot number into the Default Shot
text field at the bottom of the main window. If no other shot information is explicitly entered into the Setup
dialog, this will then mean that all data is retrieved and plotted for that shot only.

ReviewPlus can do much more than this, however. It is possible to plot your signals for multiple shots.
You can plot signals for multiple shots, and select certain signals to plot for only one shot. It is also
possible to use the current shot for your experiment, or shot numbers relative to it. This additional
complexity is explained below.

The Shot Number Algorithm

The following algorithm describes how the three areas in which to enter shot numbers are used to
determine the shot(s) for which to retrieve data.

For each row in the table, the first question to answer is whether to use the shots entered in the Shot
List section of the Setup dialog (identified by the label LIST OF SHOTS TO PLOT), or whether to
use one specific shot number for that row (and only that row). This is determined by the value in the
column Use List? for the row in question.

If Use List? is set to Yes, the signal is retrieved and plotted for all the shots listed in the Shot List
part of the dialog. If Use List? is set to No, ReviewPlus will use the shot number entered in the
column Shot instead.

In most cases, it is sufficient to leave Use List? set to Yes for all rows, and then just use the Shot
List part of the Setup dialog to control the shot numbers. However, if you want to plot one or more of
your signals for a specific shot regardless of what shots are in the Shot List, then enter that shot
number into the Signal table under the column Shot (which automatically changes the value under
Use List? to No). Clicking on the cell in the column Use List? allows you to easily toggle between
using the shot list and the specific shot in the Shot column for a given row.

The other question to answer in order to determine which shot numbers are used is whether or not
there are any "relative shot numbers" *anywhere* in the Setup dialog, either in the Shot List section,
or in the Shot column of the Signal table. (Note that the latter's value only matters for a row if the
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value of Use List? for that row is No.) A relative shot number is a number less than or equal to
zero. Recall that a blank field is equivalent to zero for shot numbers.

If a shot number less than or equal to zero appears anywhere in the Setup Dialog, this value is
added to the value appearing in the Default Shot field at the bottom of the main dialog. To make this
concrete, assume that the following is true:

• the number 104276 is entered into the Default Shot field on the main dialog window, and
• one row in the Signal table has 0 entered under the Shot column and Use List? is set to No

For this row, then, the value 0 is added to the default shot 104276, so that the data is retrieved for
shot number 104276. If -5 is entered in the Shot column, then the shot number that is used is
104271.

The same applies if 0 or -5 is entered into the Shot List part of the Setup dialog and Use List? is set
to Yes.

The Simplest Way to Enter Shot Numbers - Revisited

Having discussed the whole algorithm for determining shot numbers, it should hopefully be clear why, in a
fresh ReviewPlus session, entering a shot number only in the Default Shot field on the main window
retrieves data for that shot. In the Signal table, all of the rows would have their Use List? value equal to
Yes, meaning that the shot numbers are determined by the shot list. Since no entries explicitly have been
made in the shot list section, the blank field is interpreted as shot 0. This means to add 0 to the value in
the Default Shot field on the main window.

Plotting One Signal for Multiple Shots

There are two ways to see the data for one signal from multiple shots. The first way is to enter multiple
shots into the Shot List part of the Setup dialog (under List of Shots to Plot as described in the
previous section). For each row of the Signal table (whose Use List? value is Yes) you will then get one
data trace per shot number appearing in the plot box. In this case, there is no way to display the traces for
each shot in a separate plot box. They are always manipulated as a unit.

To display the same signal expression for different shots in different plot boxes, make multiple entries of
the signal in the Z Data Signal column, then type separate shot numbers for each row in the Shot
column. Recall that when you type an entry in the Shot column, ReviewPlus automatically sets the Use
List? value to No.

List of Shots to Plot

As stated earlier, when one signal expression is entered in the Signal table, and data is retrieved for
multiple shot numbers, ReviewPlus will display the resultant signal traces in a single plot box. In general,
each Signal table row entry will have one data trace plotted for each shot, so one row may have multiple
traces associated with it.

Use the menu command Edit>Set Signals to open the ReviewPlus Setup dialog. There are 3 easy
ways to enter shot numbers using this dialog.

You can:

• create a list of shots to plot
• specify a range of shots
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• construct an SQL query that will return a list of shots that adhere to parameters you supply

Near the middle of the ReviewPlus Setup dialog is the sentence "LIST OF SHOTS TO PLOT" below
which are controls used to enter shot numbers. To enter a single shot number, click the radio button
marked List of shots, and type the shot number into the text field. Then, click the Apply button near the
bottom left side of the dialog.

Multiple shots can be entered using the same method. Type the shot numbers (separated by spaces or
commas) into the text field to the right of List of shots, and then click Apply. ReviewPlus will plot one
signal expression from multiple shot numbers onto a single plot in the main display window, overlaying
the signal traces, and supplying different colors for each trace.

A range of shots can be plotted using the radio button in the Setup dialog. After clicking the Range of
shots radio button, enter the baseline shot number in the text field, and then choose how many previous
shots to plot by entering the number in the 'and previous' text field.

You can also specify a list of shots to plot via SQL query. The DB Query radio button provides the
opportunity to construct relational database queries and return lists of shots that adhere to the supplied
parameters.

Note that retrieving shot numbers via database query only works if that capability has been built into the
system at your location. ReviewPlus expects to find tables indexed by shot number in a relational
database that it can access. Typically, these tables would contain scalar parameters summarizing shots
from the experiment at your site (e.g., maximum plasma current, maximum stored energy, etc.).
ReviewPlus can query this summary information to determine a list of shots to use for retrieving and
plotting data.

ReviewPlus constructs an SQL query to generate the list of shots as follows:

Select SHOT from [...]

where [...] is a valid SQL clause completing the statement.

For example, to generate a list of shots where the maximum plasma current was at least 1.2 MA, enter
the following text into the text field:

SUMMARIES where IP>1.2e6

ReviewPlus adds "Select SHOT from" to the beginning of this string, to produce the query:

Select SHOT from SUMMARIES where IP>1.2e6

This example works for the General Atomics DIII-D relational database, which contains a table called
"SUMMARIES" that stores scalar highlights of the shot data from MDSplus and PTDATA. One of these
highlights is the column "IP," defined to be the maximum plasma current for each shot.

Since a query could return many thousands of shots, there is a limit imposed on the number of shots
plotted in ReviewPlus. This limit is adjustable using the drop-down list next to the query field. Choose a
limit of 5, 10, 25, 50, 100, 200, 300, 400, or 500 shots. The default value for this field is 5. To see the
shots returned, click the button Show result [N], where [N] is the number of shots returned.

Unique Shot Numbers and the Shot Column

You can define a specific shot number for an individual signal expression by entering the shot number in
the Shot column of the Signal table. It is possible to create separate plots of the same signal, taken from
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different shots, by making multiple entries of the signal expression in the Z Data Signal column, and then
typing separate shot numbers for each entry in the Shot column. When you type an entry in the Shot
column, ReviewPlus automatically sets the Use List? value to No. You can toggle between shots by
clicking on the setting in the Use List? column of the Signal table provided the shot numbers are entered
correctly in the Shot column and in one of the other areas in ReviewPlus.

More on Relative Shot Numbers: Blank, Zero and Negative Shots

Recall that anywhere a field specifying a shot number is left blank, the value is interpreted as zero. Shot
numbers less than or equal to zero are referred to as "relative" shot numbers. The meaning of these shot
numbers, that is, what they are taken relative to, depends on where they appear.

As described in The Shot Number Algorithm, if a relative shot number appears *anywhere* in the Setup
dialog, either in the Signal table or the List of Shots to Plot, the number is added to the "default shot" -
the value in the Default Shot field on the main window.

If the default shot is itself blank or zero, then the current experimental shot is used. (At GA, this would be
the current DIII-D shot.) If the default shot is negative, its value is added to the current experimental shot.
Entering -1 as the default shot would then give the previous shot, for example.

This makes it easy to follow the experiments over the course of a day. Just leave the default shot equal to
zero, and use shot 0 somewhere within your shot list in the Setup dialog. That shot will then always
reflect the current experimental shot number.

Just to confuse things, suppose that -1 is entered in the shot list, and -1 is also entered as the default
shot. In this case, the shot that will be used is *two* less than the current shot. This is because the -1 in
the shot list means "subtract one from the default shot," while having the default shot equal to -1 means
"subtract one from the current shot." The result is the current shot -1 -1 = current shot -2.

Automatic Updating

If your facility supports MDSplus events, you can have ReviewPlus automatically refresh your data and
graphs when the shot number changes and new data becomes available. To do this, check the box
labeled Auto Update next to the Default Shot field on the main application window.

Note that this feature is not very efficient (MDSplus Scope users will especially be concerned about
this). This is because when an event is heard and the shot number has changed, ReviewPlus attempts
to retrieve all the specified signals at once. At DIII-D, it is not setup to distinguish different events
signifying the availability of different datasets. If ReviewPlus is unable to retrieve some of its signals after
the first event, it will try those again when it hears its next event. This continues until all the signals
specified in the Signal table have been retrieved for the current shot, or until the current shot changes (at
which point the process begins over again).

The MDSplus Scope is able to update individual plots as soon as the data for those plots becomes
available. This is because separate events for each dataset are declared, and are known to the user
community. At DIII-D, signal-specific events are available, but the user community currently has no easy
way of learning them all. The plan for DIII-D and ReviewPlus is to use the relational database to keep
track of what events belong with what signals, so the application is automatically configured to update
itself if the user desires.
MDSplus Scope users take note: When this feature is added, an extra column in the Signal table will be
added as well so that you can input the event names manually. Stay tuned for more information.
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Creating and Restoring Shot and Signal Lists

Lists of shots and signals can be stored in *.revplus files. You can selectively control the data imported
when a *.revplus file is opened using the Restore shots and Retrieve data checkboxes in the
Restore dialog.

See Restoring Shot and Signal Lists for more information.
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Interacting With Plots

As stated in the Introduction, ReviewPlus is a general-purpose plotting tool, capable of displaying
interactive 2D and 3D plots of raw, analyzed, and simulation data. This section looks at how those plots
are generated.

Defining the ReviewPlus Coordinate System

• 2D data is considered as a function of one variable, Z(X).
• 3D data is considered as a function of two variables, Z(X,Y).

Figure 10: ReviewPlus Coordinate System

• X always refers to the first dimension of the signal, determined by how the data is stored in
MDSplus or PTDATA.

• Y refers to its second dimension, if the signal is 3D. If the signal is 2D, Y is unused.
• Z always refers to the dependent data (the measured or calculated parameter).

Defining 2D Plots

When plotting 2D data versus time, for example IP from PTDATA, Z = IP and X = time. ReviewPlus
shows the plot in the X-Z plane as a 2D image.

Here, it is displayed as a 3D image to make the point that the Y dimension is unused.

Figure 11: Plot IP versus time
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When plotting 2D data that is measured versus some parameter other than time, the plot is also shown in
the X-Z plane.

For example, suppose that the data below represents Te from the old single pulse Thomson Scattering
system at the DIII-D facility. This system measured Te at one time only but at many positions in the
plasma. Here, Z = Te and X = elevation (or "z" to be confusing). ReviewPlus would display this as follows
(remember that it shows only the X-Z plane - the 3D image is shown here for instructional purposes only):

Figure 12: Plot of Te from single pulse system versus elevation

Defining 3D Plots

There are five types of 3D plots displayed by ReviewPlus:

1. Surface
2. Image
3. Contour
4. ZvsX
5. ZvsY

• Surface, Image, and Contour plots show the data as a function of both of their dimensions.
• The ZvsX and ZvsY plot types show the data as a function of one of their dimensions, calculated

for a fixed value of the other dimension.

You can access the 3D Plot Type settings using Edit>Set Appearance, or with the RMB>Set
Appearance command.

The example below shows Te from the core system of the modern Thomson Scattering diagnostic at the
DIII-D facility: this is the signal TSTE_CORE. (The data have been smoothed to make it easier to see the
profile.) TSTE_CORE is stored in MDSplus with time as its first dimension and elevation as its second
dimension, so here Z(X,Y) = Te(time, elevation).

Plotted as a Surface, ReviewPlus would show:



ReviewPlus User Manual © 2001 30

Figure 13: Surface plot of Thomson Te (time, elevation)

Defining 3D Plot Slices

3D data can also be "Sliced" to show Z as:

• a function of X for a fixed value Y = y0 (Plot Type ZvsX)
• a function of Y for a fixed value X = x0 (Plot Type ZvsY)

For the TSTE_CORE plot in Figure 13, the X units are ms and the Y units are m. ZvsX and ZvsY plots
of TSTE_CORE for sample values Y = y0 and X = x0, respectively, are shown in Figure 14.

Figure 14: ZvsX and ZvsY "Slice" plots of TSTE_CORE

Of course, ReviewPlus does not display the plots projected in 3 dimensions. Instead, it shows the plots
as you would expect - see Figure 15.
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Figure 15: ZvsX and ZvsY "Slice" plots of TSTE_CORE as shown by ReviewPlus

The q profile from EFIT, signal name QPSI, is an example of a profile stored in MDSplus whose X
dimension is not time; instead X = normalized psi and Y = time.

A surface plot of QPSI is shown in Figure 16.

Figure 16: Surface plot of EFIT q(normalized psi, time)

The ZvsX and ZvsY slices of QPSI, as they are actually displayed by ReviewPlus, are shown in Figure
17.



ReviewPlus User Manual © 2001 32

Figure 17: ZvsX and ZvsY "Slice" plots of QPSI

Defining 3D Plot Types

You can determine the type of plot used for displaying 3D data by selecting the menu command Edit>Set
Appearance, and then selecting a 3D Plot Type. The default setting for a plot type is ZvsX. If you set up
a signal in ReviewPlus and notice that the 3D Plot Type drop-down list has been disabled, it means that
the signal data is two dimensional and can be shown as ZvsX only.

Open ReviewPlus on your system and restore the example file example_plot_types.revplus.

The file restores 5 different views of the Electron Temperature Profile TSTE_CORE:

1. 3D Surface plot
2. 3D Contour plot
3. 3D Image plot
4. ZvsX plot
5. ZvsY plot

The first three plots in this display show the entire 3D data set at once. The last two plots show slices of
the data set.

Click in the fourth plot (ZvsX) and then select the menu command Edit>Set Appearance. Near the
bottom of the Set Appearance dialog is the Y Slice control. Use this slider to change the position of the
slice on the Y axis of the 3D plot. Notice how the profile changes for each different position on the plot.
For finer control of the slice position on the Y axis, you can type a font into the text field next to the slider.

You can also change the look of the profile trace in the ZvsX plot by placing symbols along the signal
trace. Use the SYMBOL drop-down list to choose a symbol type. You can alter the properties of the
symbols using the Symbol features controls: fill, size, and fraction. You can also alter the signal trace
using the LINE drop-down list to choose another line style, or to remove the line altogether. Press Apply
to commit your changes to the plot, or press Done to commit your changes and dismiss the Set
Appearance dialog.
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Changing the Line, Symbol, and Slice characteristics for the ZvsY plot are the same as for the ZvsX
plot, except that the slider now controls the slice position on the X axis and you can type a value in the
text field to specify where to slice on the X axis.

The Surface plot type (the upper plot in the example) displays a 3D map of the signal, with datapoints
connected by surfaces. When selected, the Set Appearance dialog contains controls for rotating the
Surface plot along the Z and X axes. You can display the 'upper half' of the plot bounding box by filling
the SHOW BOX checkbox. There are four Surface plot styles to choose from: Shaded, Mesh,
Horizontal, and Lego. For more information on these styles, consult the IDL Reference Guide for the
functions 'SURFACE' and 'SHADE_SURF'.

The Contour plot type displays contours of constant Z value projected on the X-Y plane (like a
topographical map). The Set Appearance controls for this plot allow you to choose the number of
contours using the slider, or you can enter your own contour levels by typing an IDL expression for the Z
axis values to use. For example, a specific set of values can be entered as [1,2,3,4]. Or, you can use IDL
function. For example, entering 10XFINDGEN(21)/20 will show 21 evenly spaced contours from Z = 0 to
Z = 10. When Crosshairs (described later) are active, you can have them track the contours by placing a
check in the box near the bottom of the dialog.

For more information, see the 'Contour' topic in the IDL Reference Guide.

The Image plot type displays a 2D 'false color' representation of the data on the X and Y axis. Data
variations on the Z axis are represented by changes in the intensity or color of the image, giving the plot
its 3rd dimension. The Set Appearance controls for this plot type allow you to Overlay Contours over
the Image plot by placing a checkmark in the supplied box. This also activates controls for the number of
contours and contour levels. You can switch between Interpolated and Rebinned Image displays
using the radio buttons. (In most cases, you can use the Interpolate method on these commands.)

See the IDL Reference Guide topics 'TV' and 'CONGRID' for more information.

Mouse Modes

ReviewPlus provides interactive signal plotting. There are different ways to interact with the plots, one of
which is the Mouse Modes.

Mouse Mode settings can be found on the ReviewPlus main display window, just above the main
display area. Each of the different settings is described below. A short summary of what the left and
middle mouse buttons do in each mode can be found to the right of the Mouse Mode radio buttons in the
main display window.

Select mode allows data or plot selection and panning. When in the Select mode, a dataset can be
selected by clicking the left mouse button in the plot, near the target dataset (the dataset then becomes
highlighted). Also, an entire plot can be selected by clicking just outside the plot border. The selected
dataset can be dragged (by clicking the left mouse button on the selected dataset and holding the button
down, then moving the mouse) and dropped (the left mouse button is released) into another plot window.
If the dataset is dropped outside of all plot windows, it is deleted (after a confirmation message is
okayed). If the left mouse button is released in the same plot window from which the data was selected,
the plot is panned and its ranges are adjusted. A single click of the middle mouse button within a plot
window resets the plot to its original ranges.

Zoom mode allows zooming from many plots in the main display window to a single plot, and vice
versa. When viewing many plots, clicking outside a single plot window while in Zoom mode fills the entire
display with the plot. Clicking outside the plot again returns you to the 'many plots' view. Zoom mode also
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allows zooming within a single plot window. While the cursor is within a plot window, you can use click-
and-drag to draw a box identifying a particular region to examine. When the mouse button is released, the
range of the plot is adjusted to display the identical region. While zoomed, a single click of the left mouse
button within the plot window returns the plot to its preset ranges; and a single click of the middle mouse
button while zoomed autoscales the plot. These two methods differ only when explicit ranges have been
set for a plot.

Cursor mode allows you to mark a reference point by clicking the left or middle mouse button in a plot
window. A crosshair is kept at the reference point with Z/X lines for the left mouse button and X only for
the middle button. The coordinates shown in the Status area are for the cursor's current position relative
to the last crosshair reference point shown in red; older crosshairs are shown in blue. To clear reference
points, simply left-click outside the plot.

Slice mode allows you to interactively slice a 2D or 3D plot and view the results of the slice in another
plot. The rules for determining which plots have their slices changed are based on the units of measure of
their axes. More about slicing is explained in Slicing 3D Plot Data.

Crosshairs turns on and off cursor tracking. Crosshairs may be combined with any other Mouse Mode.

If Crosshairs is on, and if no dataset has been selected in a plot window, then the readout in the Status
area (near the bottom left corner of the ReviewPlus main display window) shows the location of the
cursor in data coordinates. If a dataset is selected, the cursor always traces the selected data. (For
example, when the cursor is at any X/Y coordinate, the Status readout will also show the Z value from
the selected data trace at that X/Y location.) When in Cursor Mode (above), the readout in the Status
area shows the difference between the cursor and the reference point.

If there are multiple plots in the main display window, Crosshair(s) are shown in every plot window
reflecting the same readout (when appropriate). See the following discussions on Displaying Ganged
Crosshairs and Slicing 3D Plot Data.

Right Mouse Button (RMB) Commands

Right Mouse Button commands (also referred to in this manual as RMB commands) are launched by right
clicking inside a plot. This action selects the plot and the RMB command is executed on the data in that
plot (unless otherwise noted).

This is a description of each RMB command:

• Autoscale: This command automatically displays the entire set of data in the plot box and sets
the ranges just beyond the extent of the data.

• Autoscale Z: This command automatically sets the range of the Z axis just beyond the extent of
the available Z axis data, within the range already set for the X or Y data.

• Autoscale All: This command applies Autoscale to all plots.

• Autoscale All Z: This command applies Autoscale Z to all plots.

• All Same Scale: This command automatically sets the range of all other plots to the range of the
active plot (that which the mouse cursor was over when the command was issued).
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• All Same X/Y Scale: This command automatically sets the range of the X and Y axes of all plots
to that of the active plot.

• All Same X/Y Auto Z: This command automatically sets the scale of the X and Y axes of all plots
to that of the selected plot, then issues an Autoscale Z command to all plots.

• All Same Z Scale: This command automatically sets the scale of the Z axis of all plots to that of
the selected plot.

• Scale to Data: Sets the range of the plot to the minimum/maximum value of the selected signal
(assuming one has been selected in Select mode).

• Ranges Dialog: Opens the GA Plot Properties dialog with the Ranges radio button enabled.
Changes made in the dialog affect the selected plot.

• Reset Scales: Resets the scales of a plot to the values in the Ranges dialog. If there are no
values set in the Ranges dialog, this command Autoscales the plot.

• Reset All Scales: Resets the scales of all plots to their default settings. If no values are set in the
Ranges dialog, this command Autoscales all plots.

• Refresh Display: Redraws all the plots. This is useful in case your X-Windows backing store fails
(your display does not automatically refresh after being exposed).

• Set Appearance: This is the same as performing the Edit/Set Appearances command for a
particular plot.

• Refresh Signal: Retrieves the signal data of a single plot from its source. The usual rules for
determining the shot number applies, so if you are using the most recent shot, and that shot has
changed, you will get data for the most recent shot.

Resizing the Main Display Window

It is possible to resize the plotting window by moving the cursor over any part of the window border, left
clicking and dragging the window border. The menu command Edit>Reset window size will reset the
window size to the default value in case the window cannot be resized manually.

Setting Common Plot Ranges

ReviewPlus allows users to set plots to the same X or Y range, either manually using the RMB
command, or automatically as a preference (see Edit>Preferences). ReviewPlus groups plots together
based on the units of the X and Y dimensions. All plots in the same group have their ranges set the same
in either of the above situations.

To illustrate how this feature works, please start ReviewPlus and load the example fill:
3dexample.revplus.

This example file makes 6 plots:

1. ZvsX: IP vs. time in ms
2. ZvsX: TSTE_CORE vs. time in ms at elevation z0
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3. Image: QPSI vs. normalized psi and time in ms
4. ZvsX: QPSI vs. normalized psi at t0
5. ZvsY: QPSI vs. time in ms at psi0
6. ZvsX: WMHD vs. time in ms

If you do not have the preference Force all plots to the same X/Y axis set, please set it now (by
choosing Edit>Preferences) so that you may follow along with the example. You should see the following
display:

Figure 18: ReviewPlus file 3dexample.revplus

Notice that plots 1, 2, 5, and 6 all have the same horizontal scale: this is because all 4 plots have time in
ms as their horizontal axis (either X or Y). The Y axis of plot 3 has units of ms as well, so its range is the
same as the X axis range of plots 1, 2, 5, and 6.

Make sure the mouse is in Zoom mode and move to plot 1. Press and hold the middle mouse button
while dragging over a small horizontal distance. This makes plot 1 the active plot and will set the ranges
of all other plots with the same units (2, 3, 5, and 6) to the same range. You should see something like
what is shown in Figure 19 (depending on what range you actually set when you moved the mouse).
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Figure 19: Same plots, after zooming in plot 1

Plot 4 is not affected as it does not have a displayed axis with units = ms. If you move to plot 4 and
perform the same type of zoom operation, the ranges of both plots 3 and 4 are adjusted - since plot 3 also
has an axis with units "normalized psi." All other plots are not affected.

Figure 20: Same plots, after zooming in plot 4
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If you Zoom inside of plot 3, then all the plots will be affected, as the units of the axes of all plots are the
same as at least one of the axes in plot 3.

Having the preference Force all plots to same X/Y axis enabled is equivalent to adjusting the range of
one plot, and then using the RMB>All Same X/Y Scale command. If you do not have the preference set,
then any time you use the All Same X/Y Scale or All Same X/Y, Auto Z commands, the behavior of the
plot ranges will be the same as described above.

Displaying Ganged Crosshairs

When the Mouse Mode - Crosshairs is turned on, ReviewPlus will draw horizontal and vertical lines at
the data coordinates in the plot in which the cursor resides. The data coordinates corresponding to the
cursor location are displayed in the lower left Status area of the main display window. In a 2D plot,
these coordinates are (x0,z0) for a ZvsX plot, or (y0,z0) for a ZvsY plot. In a 3D plot, these coordinates
will be (x0,y0) if there is no data object selected, or (x0,y0,z0) if there is. z0 is the value of the selected
data object at coordinates (x0,y0).

ReviewPlus will also draw a horizontal line at Z = z0 in all other 2D plots regardless of their units. In any
plot, 2D or 3D, whose X or Y units are the same as the X units of the active plot, a line perpendicular to
the axis will be drawn at X = x0 or Y = x0, accordingly. A similar situation holds for any plot whose X or Y
units match the Y units of the active plot - a perpendicular line is drawn at X = y0 or Y = y0.

Once again, refer to ReviewPlus and the example file 3dexample.revplus to see this in action. Turn
Crosshairs on and move into plot 1. The location of the mouse cursor is shown as an arrow in Figure 21.
In plots 2, 3, 5, and 6 you should see lines at the time corresponding to the cursor location. In plot 3,
since time is the Y axis, the line is horizontal; in all the other plots, the lines are vertical. This is shown in
Figure 21.

Figure 21: Crosshairs shown plots when the mouse is in plot 1
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Notice in Figure 21 that the Z value corresponding to the cursor location in plot 1 is about 8x105. Plot 6 is
the only other plot that has this value in its Z range, so it is the only other plot that has the horizontal
crosshair line.

If you move the cursor into plot 3, then there will be crosshairs displayed in all plots, as shown in Figure
22.

Figure 22: Crosshairs shown on plots when the mouse is in plot 3

Slicing 3D Plot Data

As explained earlier, for 3D data, the plots ZvsX and ZvsY show slices of the dataset at a "slice value" Y
= y0 and X = x0, respectively. In the Mouse Mode - Slice, the slice values of plots can be changed
interactively by moving the cursor in any plot.

The rules for determining which plots have their slices changed are also based on the units of the axes.
Assume that the active plot, that is the plot in which the cursor is being moved, is a ZvsX plot (can be 2D
or 3D data). Let Xu be the units of the X axis of the active plot. In any other 3D slice plot (ZvsX or ZvsY)
where the units of the axis not plotted equal Xu, the slice value is changed. Note that in a slice plot the
units of the axis not plotted are just the units of the slice value.

The same holds if the active plot is ZvsY: any other slice plots, where the units of the slice value match
Yu, have their slice values changed. If the active plot is a 3D plot (a Surface, Image, or Contour), the
units of the slice values of all other slice plots are compared to both Xu and Yu, the units of its X and Y
axes. If there are any matches, the slice values are adjusted.

With the ReviewPlus example file 3dexample.revplus, set the Mouse Mode to Slice. Move the
cursor into plot 1 (IP vs. time) and turn slice mode on by pressing the left mouse button. Move to a
different time value and notice that plot 4, which shows q vs. psi for a fixed time t = t0, changes to show
the profile at the time corresponding to the cursor location in plot 1.
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An example is shown in Figure 23.

Figure 23: Slicing plot 4 by moving in plot 1. Plot 4 shows q vs. normalized psi at t = 1000ms, the location of the
crosshairs in plot 1.

If you move the cursor in plot 4, then only plot 5 has its slice value adjusted. This is because plot 5 is the
only slice plot whose slice value has the units "normalized psi."

Figure 24 shows the cursor sitting at normalized psi = 0.8 in plot 4 and the time history of q(norm. psi =
0.8) in plot 5.
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Figure 24: Slicing plot 5 by moving in plot 4.

Note that plot 2, which shows Te(t, z = z0), was not affected by moving in plot 4, as their units are not
commensurate. However, moving in plot 2 will affect plot 4, since the units of the slice value of plot 4, and
the units of the X axis in plot 2, are both time in ms.

Units of Measure - In Depth

ReviewPlus bases its behavior for setting ranges, ganging crosshairs, and slicing data on the logical
units of measure of the data signals. These are displayed (in read-only cells) in the Signal table.
Sometimes an ambiguous situation arises with the units. For example, TSTE_CORE from the Thomson
Scattering system is Te(time, elevation), where elevation is measured in meters. The composite ion
temperature profile from CERQuick analysis, CERQTI is Ti (time, radius), where radius is also measured
in meters. Clearly, while the physical units of their spatial dimensions are the same, it is not desirable to
show them on the same scale, or to slice one based on the other.

It is also possible for a signal to be stored without units. In this case, the signal will not interact with any
other signal: no other signal will be set to its axis range, and no other signal will be sliced based on it. It
may be, however, that the user wants the signal without units to interact with other signals.

ReviewPlus allows the user to change the character string it uses to identify the logical units of the X and
Y (if present) axes. This is done by entering a string in the columns set X units and set Y units in the
Signal table. If there is a non-blank string in one or both of these columns for a given signal, ReviewPlus
will use the string(s) as the X (and Y) logical units instead of the units stored with the signal.

NOTE THAT CHANGING THE UNITS DOES NOT TRANSFORM THE SIGNAL! If a signal is stored with
X = time in ms and Y = normalized psi, and you enter the string ms in the column set Y units, you will not
cause the signal to be transposed. Instead, ReviewPlus will think that the units of Y are ms as well,
resulting in some very confusing behavior when it tries to set ranges or slice data. The value of the logical
units string is not relevant, only whether the string matches the logical units of other signals matters.
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To see this in action, load the example ReviewPlus file ts_cer_example.revplus. The file shows
TSTE_CORE and CERFTI in their default behavior - both have Y logical units = m. If you have the
preference Force all plots to the same X/Y axis set, then any range change in one plot will set the
range of the other plot as well, so that you will not be able to see both profiles simultaneously (unless you
expand the range to cover 0 to 2.5 m). To fix this, go to the Signal table and enter Z(m) in the set Y
units column for the CERFTI profile. After doing Autoscale all (using the RMB command), you should be
able to see both profiles simultaneously. The value of the string entered in the set Y units column does
not matter - it only has to be different than the Y units of TSTE_CORE. You could enter gizmos instead
and see the same behavior. ReviewPlus will remember these settings if you save the file and return to it
later.

CAUTION! ReviewPlus will remember the units setting if you change the signal. Using the above
example, if you change the signal CERFTI to TSTE_CORE (for example, in preparation to display an
image plot of Te and a slice plot), the logical units of the second TSTE_CORE will still be Z(m) (or gizmos
if you entered it). You will need to erase the value in the set Y units column for ReviewPlus to behave as
expected.

Transforming Signals

Signal traces can be transformed in a variety of ways. A signal must first be selected before it can be
transformed. Use either the Mouse Mode - Select and then click the signal trace, or use the menu
command Edit>Set Appearance, and select the signal from the Select signal to configure window.
Then, click the menu command Transform and choose a specific transformation to apply to your
selected signal trace.

You can transform a signal using:

• Derivative: This command takes the derivative of the selected signal trace.
• Integral: This command will integrate the selected signal trace.
• FFT: This command implements a Fast Fourier Transform on the selected signal trace.
• Smooth - boxcar: This transformation individually averages all signal trace datapoints within a

set range from each point.
• Smooth - triangle: This transformation averages each datapoint with those near it, using a linear

falloff function as the sampled points get farther away from the averaged point.
• Smooth - causal RC: This transformation averages each datapoint with those near but only

preceding it in time, using an exponential falloff function as the sampled points get farther away
from the averaged point.
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Customizing the Appearance of Plots

You can further customize the way ReviewPlus displays plots and signals by selecting Edit>Set
Appearance and using:

• Configure: Signals
• Configure: Plot Properties
• Configure: Ranges

You can access the Configure Ranges dialog either through Edit>Set Appearance, or through the
RMB>Ranges command.

Configuring Signal Appearance

To configure the properties of a particular signal, first select Edit>Set Appearance, then click Configure:
Signals (if not already selected). Select the signal by clicking the signal name in the Select signal to
configure window.

Figure 25: Plot Properties Dialog – Configure signal properties

Once the signal is selected, the controls to the right of the selection window become enabled. You can
Deselect the signal, Scale the plot to the range of the signal data, Copy the signal, or Delete it from the
current display.

There are three main configuration controls in this dialog:
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• Label: ReviewPlus allows you to custom-label each signal in your setup list using the Label
command on the Set Appearance dialog. ReviewPlus will (by default) automatically label signals
if the Set automatically checkbox is filled. If you add $SHOT and/or $SLICE to your custom
label, ReviewPlus automatically adds the shot number and/or slice value to the label as direct
text replacements for these two entries wherever they appear in your label.

• X scale factor: You can scale the X dimension of a signal by adjusting the values of the X scale
factor fields. This actually performs a simple transformation on the signal. Below is the equation
used for this scaling:

X = X * [a] + [b]

where [a] and [b] are values you supply. By default, ReviewPlus sets [a] = 1 and [b] =
0.

See Tutorial 1 for an example.

• COLOR: ReviewPlus gives you control over the colors used to display your plots. The COLOR
drop-down list provides an easy method of changing the color of a signal trace and its legend and
can also change the color of 3D plot types. Simply click the signal you want to modify in the
Select signal to configure window, and then choose a color from the drop-down list.

o Edit Color Table: use the button next to the COLOR drop-down list to change the
available colors and gradients in the color table that are used for the Surface and Image
plot types.

See the IDL documentation for more information on setting and using the color table.

Configuring Plot Properties

To configure the properties of a particular plot, first select the plot in the Edit>Set Appearance dialog by
clicking the plot title in the Select plot(s) to configure window, and then click the Configure: Plot
Properties radio button.
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Figure 26: Plot Properties Dialog – Configure plot properties

Once the plot is selected, the controls to the right of the selection window become enabled. You can
Deselect the plot, Zoom the plot so that it inhabits the entire main display window, or Delete it from the
current display.

Customizing Plot Labels

There are a variety of controls that allow you to customize the labels and titles applied to the plot:

• Plot title: This control provides you with the ability to place a text title above a plot in the
ReviewPlus main display window.

• X axis label: This allows you to provide a text label for the X axis of a plot.
• Y axis label: This allows you to provide a text label for the Y axis of a plot.
• Subtitle: This control provides you with the ability to place a text title below a plot in the

ReviewPlus main display window.
• Character size: This control adjusts the size of the symbols used for your titles and labels.
• Legend: This checkbox toggles the list of signals in a plot window.
• Char size: This control adjusts the size of alphanumeric characters used in a plot window.

Customizing Plot Scales

There are also controls that allow you to configure the appearance of the plot scales:

• GRID:
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o Grid: This checkbox toggles a graphical grid in the plot window.
o Zeroline: This checkbox toggles a line at X = 0 in the plot window.
o Style: This slider allows you to change the style of the grid lines and zerolines.

• LOG SCALE:
o X axis: Implements a logarithmic scale on the X axis of the plot.
o Y axis: Implements a logarithmic scale on the Y axis of the plot.

Configuring Plot Ranges

To configure the ranges of a particular plot, first select Edit>Set Appearance, click on the plot you want
to configure in the Select plot(s) to configure window, and then click Configure: Ranges. An alternate
way of opening the dialog is by clicking in the plot you want to configure and using the RMB>Ranges
command.

Figure 27: Plot Properties Dialog – Configure range properties

You can specify particular ranges for each axis scale of a plot using these controls. Note that setting
these ranges can also affect other plots if you have enabled the Force All Plots to Same X/Y Axis
preference and the plots share a common axis. You can enter minimum and maximum numerical ranges
for the X, Y, and Z axes of your plot(s) and control the number of major and minor ticks in the scale using
the sliders to the right. Make certain that your maximum range for a given axis is greater than your
minimum range.
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Changing the Plot Grid

You can use the Edit>Change Plot Grid menu command to modify the way multiple plots are displayed
on the screen.

Figure 28: Plot Window Grid Control

ReviewPlus can automatically determine how many rows and columns of plots it displays, or you can
manually set the number of rows and columns. Click the Automatically or Manually radio button to set
your preference. If you choose Manually, use the sliders to control the maximum number of rows and
columns. Click Done when you're satisfied with the settings.
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Customizing ReviewPlus Preferences

Setting ReviewPlus Preferences allows you to define file paths that the program uses, control
functionality within the entire program, and control how the ReviewPlus main display window appears.
Use the menu command Edit>Preferences to launch the Preferences dialog.

Figure 29: ReviewPlus Preferences Dialog

Setting Environment Search Paths

• 4D functions path: ReviewPlus can accept IDL procedures you construct as signal expressions
for plotting “user written data procedures.” ReviewPlus must be able to find these procedures in
its search path in order to use them. In the example above, the directories /link/idl,
~/.4d/functions and /d/4dlib/functions are already a part of the search path. You can add
directories to the search path by typing IDL paths (colon delimited) into the text field at the top of
the Preferences dialog.

• Directory for DATA_ and e0 files: This points to a local directory for holding legacy data files
from REVIEW and the "summard" code.

• MDSplus data server: This text field contains the IP address of the default MDSplus data server
from which ReviewPlus retrieves shot and signal data. You can change the default MDSplus
server by typing a new IP address into this field.
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Customizing Program Functionality

• Ask to save before changing/quitting?: Selecting Yes causes ReviewPlus to generate a
popup dialog box whenever you clear your main display window or quit the program; the popup
dialog asks you to save your current signal configuration and display. Selecting No causes these
commands to execute immediately, without confirmation.

• Apply changes to signal dialog immediately?: Selecting Yes forces ReviewPlus to perform
changes to signals immediately, without confirmation. When working in the ReviewPlus Signal
table, if you type an entry into a new row, you need to use the Apply button at the bottom of the
dialog. If there is already an entry in that row that has been retrieved once (if there is an entry in
the Status column) and you make a change and move the cursor out of the cell, the change will
be applied immediately. If you don't want changes applied immediately, change this preference to
No. This way you can edit >1 row quickly.

• Force all plots to same X/Y axis: Choosing Yes means that ReviewPlus signals are displayed
with their common parameters (if any) falling on the same axes (either X or Y). Choosing No
means that the plots will display in their default manner. For more information, see Setting
Common Plot Ranges.

• Cursor indicates mouse mode: Choosing Yes causes ReviewPlus to alter the appearance of
the cursor, depending on the Mouse Mode setting (found near the top of the main display
window). Choosing No leaves the cursor the same for all Mouse Modes and gives better
performance to ReviewPlus for remote users.

Customizing the Main Display Window Appearance

• Number of image colors: This setting limits the total number of colors displayed by ReviewPlus.
The new setting only takes effect after quitting and restarting the program.

• COLOR: These three radio buttons control the appearance of the main display window. You can
choose to display in Greyscale, Color, or BW (black and white).

• SCREEN Foreground/Background: These two radio buttons control the foreground and
background colors used in the main display window. You may choose White on Black (white
foreground images over a black background) or Black on White (black foreground images over a
white background - the default setting).

• Character size multiplier: You can adjust the size of alphanumeric characters in the main
display window by changing the value in this field.

• Done: Applies the current settings and dismisses the Preferences dialog.

• Apply: Applies the current settings.
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File Operations

This section describes how to use the File> operations in ReviewPlus to save and restore your work.

Saving Files

The File>Save command allows you to save the displayed shot and signal configuration as a *.revplus
file. The command opens a standard save dialog box, prompting you to type a name for the file and save
it in your directory of choice. If the display configuration has already been saved to disk, File>Save will
automatically write the current configuration to disk, using the previously saved filename and directory.
The File>Save As command also allows you to save the displayed shot and signal configuration as a
*.revplus file. The command opens a standard save dialog box, prompting you to type a name for the
file and save it in your directory of choice.

Restoring and Opening Files

The File>Restore command imports a previously saved shot and signal configuration. Depending on
content of the file and the settings of the Restore shots and Retrieve data checkboxes, File>Restore
may import only shots or signals and may not retrieve signal data until you choose to do so.

Figure 30: Restore a ReviewPlus File Dialog
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File>Restore Operations

Here is a description of the commands in the Restore a ReviewPlus File dialog:

• Path (text field): You can type the full pathname to a directory containing *.revplus files in this
text field. Click Update or press [Enter] after you're done typing.

• Filter: You can use this text field to filter files during your search. Simply enter a wildcard
character and the proper file extension (usually *.revplus) to show only those files in the
current directory with that extension. Click Update after you're done typing.

• Path (display area): This display area shows the listing of directories within the current working
directory and can be used to interactively navigate within the directory structure.

• File (display area): This displays the listing of filtered files within the current directory. Only files
with names that contain the text shown in the Filter field will be listed. You can click on a file in
the list to have ReviewPlus automatically restore it.

• File (text field): This displays the full pathname of the file you select, or you can type any file
name here. Click Update after you're done typing.

• Selected: This display shows the path to the last file you selected.

• Restore shots: If this box is checked, the shot numbers previously saved in the *.revplus file
are loaded into ReviewPlus. When left unchecked, ReviewPlus will not load shot numbers from
the file and will retrieve signal data for the shot numbers you have currently entered in
ReviewPlus.

See Restoring Shot and Signal Lists for more information.

• Retrieve data: If this box is checked, ReviewPlus will load the signal list from the stored file and
will retrieve the signal data from the server and display the signal plots. If left unchecked,
ReviewPlus will only load the signal list and will display the ReviewPlus Setup dialog.

See Restoring Shot and Signal Lists for more information.

• Hide: Pressing this button dismisses the Restore a ReviewPlus File dialog.

Restoring Shot and Signal Lists

Lists of shots and signals can be stored in *.revplus files. You can selectively control the data imported
when a *.revplus file is opened using the Restore shots and Retrieve data checkboxes in the
Restore dialog. Use the menu command File>Restore, and then use the Restore dialog to browse to
your *.revplus file. Upon opening the file:

• if the Restore Shots checkbox is filled, ReviewPlus loads the shot list from the file into the
Setup dialog.

• if the Restore Shots checkbox is empty, ReviewPlus refrains from loading saved shot numbers,
instead retrieving the saved signals for the shots already entered in the Setup dialog.



ReviewPlus User Manual © 2001 52

• if the Retrieve Data checkbox is filled, ReviewPlus loads the signal list from the file into the
Signal table, and retrieves and plots the signal data.

• if the Retrieve Data checkbox is empty, ReviewPlus loads the signal list from the file into the
Signal table, but does not retrieve or plot the signal data.

Assuming you have two favorite lists, one for shots and one for signals, you can restore the *.revplus
file that contains only shot numbers, and then, with the Restore Shots checkbox empty, restore the file
that contains only signals. Now, both of your lists have been loaded into ReviewPlus, and the program
proceeds to retrieve and plot your data. If you wish to make adjustments to your lists before retrieving
data, remove the check from the Retrieve Data checkbox before restoring your signal list.

Importing Files from Other Programs

You can use ReviewPlus to open plot definition files from other programs, such as REVIEW, 4D, and
Scope. You can import a *.rev, *.pts, or *.dat file using the Restore dialog.

Restoring Example Files

The File>Restore Examples command opens the Restore a ReviewPlus File dialog and displays the
directory that contains the example files referred to in this User Manual, provided the example files were
placed there by your system administrator when ReviewPlus was installed. The directory may also
contain other files placed there by the system administrator.
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Print Operations

To print from ReviewPlus, select File>Print. The program then prints a graphic of the plot boxes in the
main display window to your default printer. The Print Setup command displays a dialog that allows
you to choose your printer, alter your print settings, or even print to a file.

Figure 31: ReviewPlus Printing Dialog

Printer Controls

Print to printer: With this box checked, ReviewPlus will print to the selected printer.

Select Printer: Pressing this button shows a list of locations and printers available for you to use.
Selecting a printer from this list will cause the printer name to show up in the Printer text field directly to
the right of the Select Printer button. You can also type the name of a specific printer in the Printer field.
Each site administrator can configure the list of printers as they choose.

Print Output File Controls

These controls allow you to select how ReviewPlus prints your file. You may also choose to have
ReviewPlus create print or graphic files instead of printing to your default printer.

• Print to file: Place a check in this box if you want to print to a file. Type the path and name of the
target file in the Filename text field to the right of the Print to file checkbox.

• Print as: You may use this checkbox to make ReviewPlus print the current display to either a
GIF or a PICT graphic file. Type the path and file name of the target file into the Filename text
field to the right of the Print as checkbox.
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NOTE: You can print to a printer, a print file, and as a graphic file simultaneously by checking the
box for each print type.

• Color: Place a check into this box to print your files in color. If you prefer monochrome, remove
the check mark from this box.

• Date Stamp: Place a check in this box to date stamp your print files. The date is printed in the
bottom right of the page. Remove the check mark from this box if you prefer no date stamp.

Print Appearance Controls

• Page Layout: You may choose the type of page layout for your print file using this drop-down list.
The choices are Landscape, IDL Portrait, Full Portrait, or Centered Square, or you may
specify your own layout using the “or specify” text field to the right of the Page Layout drop-
down list. Try the command to see examples of the page layout styles.

See the IDL Reference Manual for more information on the Postscript device.

• Font: You can use this drop-down list to choose the font style for your print files. The choices are
Helvetica, Courier, Hershey, AvantGarde, Schoolbook, or Times. You may also specify your
own font by typing its name into the “or specify” text field to the right of the Font drop-down list.

• Line thickness: You can use the default line thickness of 3.0 in your plots, or you can change the
thickness by typing a new value into the text field. This feature is often useful when making
viewgraphs.

• Char. Thickness: You can use the default character thickness value of 2.5 for your plots, or you
can change the character thickness by typing a new value into the text field.

Print Dialog Buttons

• Print: Executes the print job.

• Cancel: Exits the ReviewPlus Printing dialog without executing the print job.

• Help: Provides you with help printing your files from ReviewPlus.
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Advanced Plotting Techniques

REVIEW Command Mode

ReviewPlus has a Command Line Mode that can be used to configure the program, using syntax from
the old REVIEW code. Command line recall works in this dialog, and you can select any command in the
History window shown below the command line. Select the menu command Edit>REVIEW Command
Mode, type your command in the field provided, and click Done.

Figure 32: ReviewPlus - REVIEW mode Dialog

The following commands are currently supported:

Command Abbreviation Brief Description Differences from REVIEW

ADD AD
Add pointnames or shots for plotting to
list

None

ALL AL
Apply remaining commands on line to
all pointnames

Only works for XMI, XMA, YMI,
YMA, PO for now

ANALYSIS AN

Analysis mode: for smoothing, etc.

Supported analysis commands:

• Smooth (triangle)
• Derivative
• Integral

(e.g., AN SM 10/D)

No need to enter EDIT mode.
Use ANALYSIS CLEAR to reset
analysis.

AVERAGE AV Smooth (e.g., AV 10)
Must specify smoothing width;
there is no settable default yet

BOX BO
0 = plot in same box as plot above
else = plot in new box

No need to enter EDIT mode

CLEAR CL
Clear list of shots (CL S) or pointnames
(CL P)

None

CURVE CU
Set index of curve for analysis and
editing

No need to enter EDIT mode. 1st
signal is CURVE 0.
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DELETE DE
Remove pointnames or shots from
plotting list

"DELETE pointname" and
"DELETE index" both work for
deleting pointnames

MOVE MO Move currently selected curve to index
Select curve with CURVE, not
GET

NEXT NE Increment current CURVE index None

PLOT PL Refresh plot
Cannot specify "PLOT
pointname" or "PLOT index" yet

POINT PO
Change the pointname for the current
CURVE index

No need to enter EDIT mode

REMOVE REM Delete the last pointname in the list None

SHOT SH Change the current default shot None

WIPE WI Same as CLEAR POINTNAMES None

XMIN
XMAX

XMI
XMA

Set the X range
Only affects ALL plots if use ALL,
or if "All Same X/Y" is set in
preferences

YMIN
YMAX

YMI
YMA Set the Y range None

REVIEW commands and features that can be added:

• PLOT pointname will add the pointname to the list and blow up the plot so that it fills the window.

• PLOT index will blow up the plot for the index so that it fills the window (like clicking outside a
plot in Zoom mode).

• ALL command will be supported for ANALYSIS.

• Ability to set ICAL, TMIN, and TMAX from the command line will be added and will work with the
ALL command.

• READ command will either be able to import REVIEW files or read ReviewPlus files.

• If READ reads ReviewPlus files, then WRITE will save a ReviewPlus file.

REVIEW features that will NOT be supported:

• SCALE and OFFSET

These can be accomplished by simply entering the data combination as the pointname. For example, to
scale the electron temperature from Thomson Scattering by .001 (convert to keV), just enter:

AD TSTE_CORE*.001,PL

These values are read when importing REVIEW files and converted to the data combination.
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User Written Data Procedures and Post Draw Procedures

You can plot data in ReviewPlus generated by IDL software programs you write. These programs are
called User Written Data Procedures. If you write a program that follows the appropriate calling
procedures, it can generate virtually any kind of data, and ReviewPlus can visualize it just as if it had
come from an MDSplus or PTDATA server. To plot the data from the Procedure, enter the procedure
name as a signal expression surrounded by backticks (`procedure`) in the Z Data Signal column or
the XorY Data Signal column of the Signal table. User Written Data Procedures can't be used as part of
data combinations in signal expressions.

Using a User Written Data Procedure as a signal expression called from the Z Data Signal column
requires that the procedure return data to ReviewPlus in a specific way.

The procedure (with the filename FOO.pro for this example) must be written in the following form for 2D
data (ZvsX):

pro FOO, shot, x, z, error

where shot (input) is the shot number
 x (output) is the x data (usually time but can be anything)
 z (output) is the z data
 error (output) is an error code indicating to ReviewPlus
 the success or failure of the procedure
 (0 = success, anything else = failure)

This is the form the procedure must follow for 3D data (ZvsX and Y):

pro FOO, shot, x, y, z, error

where shot (input) is the shot number
 x (output) is the x data
 y (output) is the y data
 z (output) is the z data
 error (output) is an error code indicating to ReviewPlus
   the success or failure of the procedure
   (0 = success, anything else = failure)

There are other optional keywords that can be used to pass arguments to the procedure FOO and return
the units for the data and dimensions.

To call the User Written Data Procedure FOO.pro from within ReviewPlus, type the following in the Z
Data Signal column in the ReviewPlus Signal table:

`FOO`

The name of the procedure must be delimited by backticks in order for ReviewPlus to recognize the
requested signal as coming from an IDL procedure.

You can also use IDL to write Post Draw Procedures that manipulate data retrieved from MDSplus or
PTDATA servers, prior to plotting. The procedure is called by entering its name in the Post Draw
Procedure column of the Signal table. This feature gives you greater control over the processing of
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signal data and its display, but it won't change any of the data retrieved from the servers. You can
overplot anything else that you want to on top of the data and also add annotations. Note that if you do
any overplotting or add annotations to the plot using a Post Draw Procedure, you cannot manipulate
those items using the interactive plotting techniques in ReviewPlus (for example, you can't select an
overplotted line using the Mouse Mode - Select). The Post Draw Procedure exists outside the ability of
ReviewPlus to enact changes on its resultant data. However, you can use the same Post Draw
Procedure with many data traces.

In both cases, you can write and store these procedures locally, provided the path to the procedures is
part of the 4D functions path in your ReviewPlus Preferences. Type the new path to your IDL
procedures in the 4D functions path field, then click Apply. The path to any other procedures that your
IDL procedure depends on must also be part of the 4D functions path.

When you use IDL procedures called by ReviewPlus, you're running programs outside of ReviewPlus.
Always follow good programming practices, and remember that a malformed program can act
unexpectedly, crash ReviewPlus, or otherwise misbehave. If you use these features of ReviewPlus, you
are responsible for the outcome.

For information on programming IDL procedures, see the IDL Reference documentation.
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ReviewPlus Tutorials

Tutorial 1 - Shifting Timebases and Plotting Signals from More than
One Server

In this tutorial, you will create a plot that compares signals from three different Tokamak reactors.

The plot will consist of the Plasma Current signals from:

• The DIII-D Facility at General Atomics in San Diego, California, USA;

• The Alcator C-Mod Facility at the Massachusetts Institute of Technology in Cambridge,
Massachusetts, USA;

• The JET Facility at the Culham Science Centre in Abingdon, Oxfordshire, UK.

The first step is to get the signals from the three machines into separate plots in ReviewPlus. This is
accomplished using the Edit>Set Signals command, which launches the ReviewPlus Setup dialog. The
first signal will come from the DIII-D Facility at General Atomics, assumed for this tutorial to be the default
MDSplus server. Click in the first cell in the Z Data Signal column and type the signal name for Plasma
Current, IP, and press [Return] or [Enter] on your keyboard.

Next, you will retrieve the Plasma Current signal from the Alcator C-Mod Facility at MIT. Click in the
second cell of the Z Data Signal column and type \MAGNETICS::IP, then press [Return]. You will need
to specify the Tree name for the data stored in MDSplus at MIT; type MAGNETICS in this column and
press [Return]. Then, you need to identify the MDSplus server at MIT by typing its IP address into the
Server column: cmoda.psfc.mit.edu.

The third Plasma Current signal will come from the JET (Joint European Torus) Facility at the Culham
Science Centre. Click in the third cell of the Z Data Signal table and type
JET("PPF/MAGN/IPLA",_shot), then press [Return]. Note that this signal name is actually an
MDSplus function which runs on the JET data server and that the shot number is being passed as an
MDSplus variable. For this signal you don't have to specify a tree, but you still need to specify the JET
server; type mdsplus.jet.efda.org in the Server column and press [Return].

Now that the list of signals is built, you need to specify shot numbers for the signals.

For the DIII-D signal (row 0 in the ReviewPlus Signal table) simply type the shot number (104276 for
this tutorial) in the List of shots field in the bottom half of the dialog.

(Note: If the General Atomics server is not your default server, you can still import the signal by typing
atlas.gat.com in the first cell in the Server column of the ReviewPlus Signal table. Then, type the
shot number in the column labeled shot. The setting in the Use List? column automatically changes to
No when you enter the shot number. Click Apply to see the resulting plot.)

For the Alcator C-Mod signal, type the shot number (960116024) directly into the Signal table in the
shot column.

Type the JET shot number (40573) directly into the table in the shot column.

Finally, click Apply at the bottom of the ReviewPlus Setup dialog to plot the signals.
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Now, the three Plasma Current traces are displayed in three different plots in the main display window.
Here, you may notice that the DIII-D signal timebase is in milliseconds, but the MIT and JET signal
timebases are in seconds. Additionally, at JET, plasma breakdown occurs at 40 seconds, but breakdown
for the other two Tokamaks occurs at 0 seconds. So, you will need to modify the signals in order to view
them all in one plot on the same axis.

First, change the colors of the second and third signal traces to make viewing the plots easier. Move your
cursor into the second plot window, right-click, and choose Set Appearance from the RMB command
menu. Use the COLOR drop-down list to change the plot color to Red, then click Done. Do the same for
the third plot window, but change the color of the JET plot to blue.

Now, you need to reset the scale of the GA signal to seconds. Right-click in the first plot window and
select Set Appearance. Use the X scale factor control to make the adjustment. Set the command to
read:

X = X * .001 + 0

(change the first text field to .001), then press Apply. This operation scales the data but doesn't reset the
scale of the plot window. Move your cursor over the GA signal plot, right-click, and select Autoscale. You
can see that all three signals are now plotted versus time in seconds.

Now you can put all three signals in the same plot. Return to the ReviewPlus Setup dialog and left- click
in the Box column on the second and third rows. This overplots the signals, creating a single plot with
three signal traces of different colors. You can see that the GA and MIT signals are lined up, but that the
JET signal is shifted by 40 seconds. To shift the JET signal, go back to the GA Plot Properties (Set
Appearance) dialog and click on the JET signal in the Select signal to configure display area. In this
case, you want to subtract 40 seconds from the JET signal timebase, so you would type -40 into the
second text field in the X scale factor command area. The equation should read:

X = X * 1.0 + -40

Press Apply. The main display window shows all three signals compared to each other.

If the sign of the plasma current isn't important, you can take the absolute value of the MIT and JET
Plasma Currents by putting the MDSplus function ABS() around the Z Data Signal expressions. For
example, the MIT Z Data Signal expression becomes ABS(\MAGNETICS::IP),and the JET Z Data
Signal expression becomes ABS(JET("PPF/MAGN/IPLA",_shot)).

With the absolute value of the signal data plotted, all three plasma current traces appear positive on the
graph.

Notice that when you change the Z Data Signal expression, ReviewPlus immediately refreshes the data
from the server. If you would rather ReviewPlus waited until you made the changes, go to ReviewPlus
Preferences and set Apply changes to signal immediately to No.
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Tutorial 2 - Slicing Data and Changing Units of Measure

For the purposes of this tutorial, please go to the Edit>Preferences dialog and set Force all plots to
same X/Y axis to Yes.

In this tutorial, you will learn to slice 3D data and to change the units of measure of a signal trace.

To start, type shot number 104276 into the Default Shot field in the ReviewPlus main display window.

(This assumes that the General Atomics MDSplus server is your default server. If this is not the case, you
can still retrieve data for this shot by typing atlas.gat.com into the Server column of the ReviewPlus
Signal table.)

Next, you will plot three different views of the Electron Temperature Profile for this shot. Choose Edit>Set
Signals, click in Row 0 of the Z Data Signal column and type TSTE_CORE, and then press [Return].
Now, click twice on the Copy button (near the bottom of the table) to enter the signal into Row 1 and
Row 2 of the table. Click Apply.

The main display window shows three identical time histories of the Electron Temperature Profile at a
given position. Notice that there is only one set of time tick marks for the X axis because all of the plots
are on the same X scale.

Now you can change your display to show three different views of the same data. Use the Edit>Set
Appearance command and click on the first plot under Select plot(s) to configure. Use the 3D Plot
Type drop-down list and select the Image plot type and click Apply. Next, click on the third plot under
Select plot(s) to configure and change the 3D Plot Type to ZvsY. Finally, use the LINE drop-down list
to change the signal trace line in the plot to None, and then use the SYMBOLS drop-down list and pick
circles to represent the plot data. Click Apply.

The three plots shown in the main display window now contain different views of the data. The first
shows the Image plot, the second shows the time history at a given position, and the third shows the
profile versus position at a given time. The two lower plots are displaying data slices of the full 3D profile,
shown in the first plot. You may also notice that the top two plots share a common X axis (time), but that
the third plot is on its own since it was changed to the ZvsY plot type (and thus shows temperature vs.
position).

Now, turn on the Mouse Mode - Crosshairs and place your cursor in the Image plot. Try moving your
cursor from left to right in the plot, holding it steady from top to bottom. As you do this, you're pointing to
different times in the plot, and the crosshair in the temperature time history below moves with you, but the
cursor in the bottom plot (profile at a given time) stays constant. If you move your cursor up and down (in
time) in the first plot window, the crosshairs in the bottom plot moves but the crosshairs middle one stays
constant.

Now, click on the Mouse Mode - Slice and click in the Image plot to enable the function. This time, as
you move the cursor (in time) from left to right in the Image plot, the time for which the profile is plotted
changes. As you move the cursor up and down (setting a different position), the position for which the
time history is plotted changes.

If you move your cursor down into the temperature profile plot and move along the trace, you only change
the position at which the time history is plotted. If you move your cursor into the time history plot and
move along the trace, you only change the time at which the profile is plotted. (This type of plotting
relationship applies to any signal, not just TSTE_CORE.)
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Next, you will add another signal into the mix. Go back to the ReviewPlus Setup dialog, highlight Row 1
in the table and click the Insert After button. This moves the contents of Row 2 down to Row 3, and Row
2 is now blank. Type IP and click Apply. (Again, this assumes that atlas.gat.com is your default
server.) ReviewPlus now displays four plots. The first three are versus time (and share X tick marks) and
the last is the temperature profile at a given time slice.

Move your cursor into the Plasma Current plot and move it around a bit. You may notice that the
crosshair follows your movement in the other two time history plots, and the time slice for which the profile
is plotted in the bottom graph changes simultaneously. This behavior demonstrates that any signal with
ms as its unit of measure can be used to slice the Electron Temperature Profile because it also has ms
as its X axis unit of measure.

Go back to the ReviewPlus Signal table and change IP to CERQTI (Ion Temperature Profile). Press
[Return] and ReviewPlus will apply the changes.

Note that the Electron Temperature Profile is measured versus elevation in the plasma in meters,
whereas the Ion Temperature Profile is measured versus major radius, also in meters. Both signals have
m as their units of measure, which creates an ambiguity.

Next, go to Edit>Set Appearance, choose CERQTI from Select plot(s) to configure, and change the
3D Plot Type from ZvsX to ZvsY. ReviewPlus places the Electron & Ion Temperature Profiles on the
same axis since they have the same logical units of measure (meters). Note that the X axis range for the
two plots is determined by the electron temperature range, which runs from approximately 0 to 0.8
meters. This range does not span the major radius range of the ion temperature profile, and thus its plot
box appears blank. This happens because the units of measure of both signals axes are meters, but
since the axes are actually physically different, they can’t both be displayed on the same range at the
same time. This problem is exacerbated by forcing all plots to the same X axis in the ReviewPlus
Preferences, set at the beginning of this tutorial.

The answer to this problem lies in understanding that ReviewPlus uses logical units of measure only as
text labels for the axes of plots, and ReviewPlus considers axes the same if they have the same text
labels. The solution for this situation is to change the label of the units of measure of the Y axis of the
CERQTI signal, separating the TSTE_CORE meters (elevation) from the CERQTI meters (major radial).

Return to the ReviewPlus Setup dialog. Scroll the Signal table to the right. Near the end of the table you
will find that the Z units for all four signals are labeled eV (electron volts), the X units column contains ms
(milliseconds), and the Y units column contains m (meters). Since the CERQTI "meters" and the
TSTE_CORE "meters" aren't identical physical units of measure, you can type a new label into Row 2 of
the Set Y Units column of the Signal table and re-label the Y units of the CERQTI signal. Since
ReviewPlus only looks for a text string as a label for logical units of measure, you can type anything you
like, such as gizmos.

When gizmos are used for the Y units, plots one and two appear on the same axis (since they share an
X axis label – “ms”), and plots three and four can both be seen together since they are now plotted on
separately labeled axes. All of the plots still share the same X axis (ms), so if you go into Slice mode and
move in time in either the Image plot or the time history of Te plot, you still change the time slice at which
the profiles are plotted. However, since the Ti profile now has a different Y axis label than the Te plots,
moving the crosshairs in the Ti plot from one radius to another does not change the position for which the
Te time history is plotted.
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Tutorial 3 - User Written Data Procedures and Post Draw Procedures

This tutorial will show you how to use IDL programming procedures in ReviewPlus, called from either the
Z Data Signal column or the Post Draw Procedure column in the ReviewPlus Signal table.

User Written Data Procedures

User Written Data Procedures can be called from the Z Data Signal column or from the XorY Data
Signal column, but they can't be used in data combinations for signal expressions.

Using a User Written Data Procedure as a signal expression called from the Z Data Signal column
requires that the procedure return data to ReviewPlus in a specific way, as described in Advanced
Plotting Techniques.

You can use the example tutorial file example_user_data.pro to see an IDL procedure in action and
to gain more understanding of how IDL procedures are constructed. If you use this file and enter its name
in the Z Data Signal column of the Signal table, ReviewPlus will display a plot containing a line with
random noise. You are encouraged to open the file in an editor to see the IDL code that was used to
generate the data and pass it back to ReviewPlus.

Post Draw Procedures

In order to use the Post Draw Procedure, you should have a basic understanding of "GA_SIGNAL"
objects. When you type in the name of a Post Draw Procedure, ReviewPlus will pass the retrieved data
(referred to by the signal expression in that row) to the procedure. ReviewPlus sends the data as an
array of GA_SIGNAL objects (one per data trace that's associated with the row). The Post Draw
Procedure uses the objects to get the data values for each of the traces. Refer to the example Post Draw
Procedure file example_linefit.pro for the syntax on how to do this. This procedure, when used with
the example file above, will perform a linear regression on the noisy line, overplot the fit, and add
annotations to the graph indicating the results of the fit. This demonstrates the ability to process data
retrieved by ReviewPlus, as well as add annotations and data to the plots. Again, please look at the IDL
procedure for details on how this was done.

Using a Post Draw Procedure, you can perform any manipulation on the data that you desire, but you
cannot affect the data that is stored on the servers (you can do anything with it, but you can't do anything
to it). You can overplot anything else that you want to on top of the data and also add annotations. Again,
see the included file for examples of the kinds of things you can do.

Note that if you do any overplotting or add any annotations to the graph, you cannot manipulate those
items using the interactive plotting techniques in ReviewPlus (for example, you can't Select an
overplotted line using the Mouse Mode - Select). The Post Draw Procedure exists outside the ability of
the ReviewPlus system to enact changes on its resultant data. However, you can use User Written Data
Procedures or Post Draw Procedures with a completely different data trace.

Example Files

You can use the two tutorial example files together to see the IDL procedures in action. Make sure that
the path to the files example_user_data.pro and example_linefit.pro is part of the ReviewPlus
search path by using Edit>Preferences, and typing the path into the 4D functions path dialog, then
clicking Apply.

Then, use the Edit>Set Signals command to call the ReviewPlus Setup dialog.
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Type:

`example_user_data`

(note the backticks) into the Z Data Signal column, and press [Return]. Click Apply. The main display
window now shows a plot of the data generated by the IDL procedure.

Next, scroll the ReviewPlus Signal table all the way to the right, type example_linefit into the Post
Draw Procedure column, and then press [Return]. Click Apply. The main display window now shows
the original IDL generated data, with a line showing the fit from the Post Draw Procedure running through
the data trace.

See the IDL Reference documentation for more on the subject of IDL procedures.
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Glossary

Autoscale

This command automatically displays the entire set of data in the plot box and sets the ranges just
beyond the extent of the data.

Box

Signals can be overplotted by clicking in the Box column of the ReviewPlus Signal table.

Contour

The Contour plot type displays contours of constant Z value projected on the X-Y plane (like a
topographical map).

Default Shot

The Default Shot area (in the bottom of the main display window) provides an easy way to enter shot
numbers and to monitor the most recent shots. When a shot number is entered in the Default Shot field,
ReviewPlus uses that shot number as its default throughout the program.

GUI

Graphical User Interface: Modern computer programs use a system of displaying and accepting
information that includes windows that appear on the computer screen and a pointer or cursor controlled
by a computer mouse device. This combination is commonly referred to as a GUI, or "gooey" interface.

ICAL

When dealing with the PTDATA system, the default value for the ICAL column of the ReviewPlus Signal
table is set to 1. If you change it to a different value, the data you request comes back in a different form.

Image

The Image plot type displays a 2D 'photographic' representation of the data on the X and Y axis. Data
variations on the Z axis are represented by changes in the intensity or color of the image, giving the plot
its 3rd dimension.

Main Display Window

The application window that opens on your screen when you start ReviewPlus is referred to as the main
display window. This window displays the plots generated by ReviewPlus.

MDSplus

MDSplus is a relatively new data repository system (like a database) for shot and signal data generated
by the fusion experiments and viewed by ReviewPlus.

Menu>Command
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Most computer programs that include a GUI (windowing interface) have a row of options just below the
top title bar of the window. Clicking on one of these options with the mouse will reveal a list of commands
that can be performed by moving the mouse cursor over the command name and left-clicking.

Menu of Signals and Pointnames

If your site maintains a signal documentation scheme in a relational database, ReviewPlus can use it to
present a menu of available signals. This menu can be accessed using the Menu of signals and
pointnames button in the Edit>Set Signals dialog.

Mouse Mode

• Select

Select mode allows data or plot selection and panning.

• Zoom

Zoom mode allows switching from the many plots view in the main display window to a single
plot, and vice versa. It also allows zooming within a single plot window to examine a subset of
data in finer detail.

• Cursor

Cursor mode allows you to mark a reference point by clicking the left or middle mouse button in a
plot window. A crosshair is kept at the reference point, with Z/X lines for the left mouse button,
and X only for the middle button. The coordinates shown in the Status area are for the cursor's
current position relative to the last crosshair reference point.

• Slice

Slice mode allows you to interactively slice a 2D or 3D plot and view the results of the slice in
another plot. The rules for determining which plots have their slices changed are based on the
units of measure of their axes.

• Crosshair(s)

Crosshairs mode toggles the cursor tracking. Crosshairs may be combined with any other Mouse
Mode.

Overplot

Multiple signal traces can be displayed in one plot box and overlayed upon each other, much like multiple
lines co-existing in the same graph.

Plot Box

One of the graphs appearing in the main dislay window.

Plot Grid

The number of plot boxes appearing in the main display window at the same time.

Post Draw Procedures

A Post Draw Procedure is a user written IDL procedure that modifies retrieved signal data and plots it in
the main display window.
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PTDATA

PTDATA is an older data repository system (like a database) for shot and signal data generated by the
fusion experiments and viewed by ReviewPlus.

Range

The numerical span that signal data inhabits.

Restore

To open a saved file in ReviewPlus and load the information stored in the file into ReviewPlus.

Retrieve

To use the shot and signal data settings in ReviewPlus to access data from MDSplus, PTDATA, or other
storage devices and return it to ReviewPlus to be plotted.

ReviewPlus

ReviewPlus is a general-purpose plotting tool, capable of displaying interactive 2D and 3D graphs of raw,
analyzed, and simulation data. It can mix and couple 2D and 3D plots in one display, providing a rapid
means of examining 3D data. ReviewPlus displays data retrieved from PTDATA and MDSplus systems
and can make use of the Internet to display data from any fusion research site with an MDSplus data
server. In addition, ReviewPlus supports User Written IDL Data Procedures, and Post Draw IDL
Procedures, making it a powerful and versatile visualization tool.

RMB>Command

A list of commands accessed by clicking the right mouse button within the plot area of the main display
window.

Scale

Adjusting the visible range of a signal by either altering the signal data or by adjusting the view of the plot
box.

Server

Signal data can be retrieved from different MDSplus servers locally using the MDSplus data server setting
in the ReviewPlus Preferences, or from locations around the world provided that access to the data has
been made available via the Internet. You can view remote data by entering the MDSplus server IP
address in the Server column of the ReviewPlus Signal table.

Signal Table

The ReviewPlus Signal table can be used to build lists of signal expressions for storage and later
retrieval. By typing signal expressions and pressing [Enter], you can enter expressions in the table just as
in a spreadsheet. Signal expressions can be manipulated within the Signal table using the buttons below
the table.



ReviewPlus User Manual © 2001 68

Signal (or signal expression)

The signal refers to the specific data retrieved from a fusion experiment. A signal expression is a
description of the specific signal data (along with any modifiers) that is entered in ReviewPlus and used
to retrieve and display data.

Shot (or shot number)

The shot number refers to a specific fusion experiment from which data will be retrieved.

Status

This column in the ReviewPlus Signal table displays the retrieval status of a particular signal expression.

Status:

The Status area (found in the lower left corner of the main display window) displays messages when the
program is performing certain functions.

Surface

The Surface plot type displays a 3D map of the signal with datapoints connected by surfaces.

Tmax

The tmin and tmax columns of the ReviewPlus Signal table allow you to enter minimum and maximum
time ranges and retrieve only a subset of data for a signal. The tmax entry must be greater than the tmin
entry for these settings to be applied.

Tmin

See tmax (above).

Transform (or Transformation)

Use the menu command Transform to perform mathematical operations on signal data and display the
results in a plot window.

Tree

If you are familiar with MDSplus and would like ReviewPlus to retrieve your signal expression directly
from an MDSplus tree, enter the tree name in the column marked Tree in the ReviewPlus Signal table.

Units of Measure

The units of measure of a plotted signal trace are displayed in the Z units, X units, and Y units column
of the ReviewPlus Signal table. Note that ReviewPlus treats axis units of measure as labels only and it
associates the axes of signals in separate plots that share a common unit of measure. These labels can
be changed to disassociate signals that share common units of measure but that refer to differing
qualities by using the Set X Units and Set Y Units columns of the ReviewPlus Signal table.
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User Written IDL Procedures

You can plot data in ReviewPlus generated by IDL software programs you write, called User Written
Data Procedures, and ReviewPlus can visualize it just as if it had come from an MDSplus or PTDATA
server. User Written Data Procedures can't be used as part of data combinations in signal expressions.

XorY Data Signal

One signal can be plotted versus another by entering the second signal expression in the X or Y Data
Signal column of the Signal table. There must be a signal expression in the Z Data Signal column of the
Signal table for this feature to work. (Also see Z DataSignal, below.)

Z Data Signal

Signal expressions are entered in ReviewPlus by selecting the menu command Edit>Set Signals,
clicking in a cell in the Z Data Signal column of the ReviewPlus Signal table and typing the expression,
then pressing [Enter].

ZvsX and ZvsY

The ZvsX and ZvsY plot types show the data as a function of one of their dimensions, calculated for a
fixed value of the other dimension.
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Relative Shot Numbers, 26
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Entering a Signal Expression, 19
Overplotting Signals, 20
Plotting One Signal vs. Another, 20
Quick Start Guide, 7
Tutorial 1, 59

Post Draw Procedures
Advanced Plotting Techniques, 55
Column in the Signal Table, 19
Tutorial 3, 63



ReviewPlus User Manual © 2001 72

Printing from ReviewPlus
Print Operations, 53

Ranges, Plot
Configuring Plot Ranges, 46
Setting Common Plot Ranges, 35
tmin and max - Signal Table, 19
Tutorial 2, 61

REVIEW Command Mode
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