
 
 
 
 
 
 
 

XC Spectro 
 

Users Guide 



 
 
XC Spectro is an IDL application used to analyze the spectral data obtained from an x-
ray crystal diagnostic.  XC Spectro is configurable for different crystals and for different 
experimental conditions and as such has several configuration files that change the 
behavior of the application.   
 
 
Configuration Data Files 
 
XC Spectro uses several data files to allow for the most general program execution.  Each 
file is tab delimited with “!” (exclamation points) marking the divisions between one 
parameter and the next.  IDL uses these marks to distinguish between one parameter and 
the next when it reads these files, therefore the formatting of these files should not be 
changed and care is necessary when modifying the parameters inside these files.  Also the 
“;” (semicolon) is a comment symbol which can be used to comment out an entire line in 
any of the configuration files.  This can be useful if you want to change a setting but 
retain the value of a previous setting for future reference, you can just comment out the 
line and make a new line for that parameter.  The parameters in each of these files are 
detailed in the appendix, however here is a brief description of the contents of each file.  
Also see the section entitled Setting up analysis for a new Data Set for the most common 
setting changes and examples.   
 
analysis.dat 
 
 

Example ascii file containing the name of the theory file (see 
vainshtein.dat) and the name of the idl function that will do the 
analysis 
 
 

default_settings.dat Default setup parameters for program execution such as name 
of file containing crystal information to use and number of 
dimensions in data set 
 

crystal.dat Contains possibly several but at least one set of crystal 
parameters 

datafile.dat  Describes input data files to be read  
mds.dat 
 

Describes MDSplus name of tree and nodes where input data is 
contained if running in mdsplus mode (set in 
default_settings.dat)  Used as an alternative to datafile.dat  
 

lines.dat Contains list of lines to fit and their corresponding 
characteristics 

vainshtein.dat Theoretical configuration file containing excitation rate 
coefficients and theoretical wavelengths etc. 

vainshtein_restore.dat 
 

An idl restore file that contains the structure of the theory file 
for idl function read_ascii 

vars.dat Contains a list of variables with initial guess values, max/min 



and correction values for each as well as initial conditions for 
varying each variable in the fit. 

 
 
Starting XCSpetcro 
 
 
To start the application first start the idl program.  Once inside IDL type at the prompt: 
 
IDL> a=xc() 
 
This will be begin the XC Spectro application and create the following widget which 
functions as the main window/interface of the XC Spectro application.  
  

 
 
Doing the above assumes that you have a license for the IDL application which can be 
obtained/purchased from http://www.ittvis.com/   However, if an IDL license cannot be 
obtained the XC Spectro application can also be run using a previously compiled version 
of the application with the freely available IDL Virtual Machine.   
 



In this section I will review all the options, features and functions available from the 
XCspectro main application window.   
 
 
 
The File Menu 
 
At the top left of the main application window you will see the “File” menu.  From the 
“File” menu there is only one menu option “Exit”.  Use “Exit” to exit the program 
cleanly, memory will be cleaned up when the application is exited this way.   
 
The View Menu 
 
The “View” menu contains several menu items each of which is used to view the settings 
as they are listed in the various input files listed in the first section of this document.  
entitled “Configuration Data Files“.  The “View” menu contains the following options: 
 
“Default Settings”   -- displays default_settings.dat  
“Parameter Settings” – displays vars.dat  
“Line Settings” – displays  lines.dat 
“Crystal Settings” – displays crystal.dat  
“Data Settings” – displays datafile.dat or alternatively mds.dat depending on the settings 

in default_settings.dat 
“Analysis Settings” – displays analysis.dat 
 
When any of these are selected a new window will appear displaying the contents of the 
file selected.  The left most column displays the name of the parameter while the columns 
to the right indicate the value associated with that parameter.  Parameters can be changed 
from these windows and changes can be saved by clicking the “Save” button on the 
bottom left corner of the window.  The save button on these windows will save changes 
to the actual files.  Therefore, once you have changed the settings those changes will be 
in effect even if you re-open the application.  Once changes have been made and saved 
you must click the “Reload Input Files” button on the main window for the changes to be 
used in your analysis.  The one exception to this is the crystal settings file.  If you chose 
“Cyrstal Settings” from the view menu you will see a window containing a drop-down 
list of the previously defined crystal settings from which you can choose by name.  
Changes can be made to the settings for use during your analysis but these changes are 
not written to the file.  Permanent changes to the crystal settings can only be made by 
manually editing the crystal.dat file.  Clicking the “Reload Input Files” button on the 
main menu after making changes to the crystal settings using the “View”->”Crystal 
Settings” function will cause your changes to be overwritten by those contained in the 
crystal.dat file.  
 
The Data Menu 
 



The “Data” menu contains the majority of the applications functionality.  Most of the 
steps needed to complete data analysis are called from within this menu.   
 
Generating Shot Lists 
 
 
If you choose  “Generate Shot List” from the “Data” menu, you will see the following 
window: 

 
 

 
 
 
First give your list of shots a filename.  The shot list you generate will be stored in this 
file and can be recalled for future use by this name.  The default_settings.dat file contains 
a parameter called Shot_File_Dir which controls the location of the output of this feature.   
Next, enter a first shot number and an ending shot number in the remaining fields.  At 
this point your shot list will include all the numbers from the ‘first shot number’ up to 
and including the ‘ending shot number.  So for example, if your first shot number is 
123456 and your ending shot number is 123458 your shot file would look like this: 
 
123456 
123457 
123458 
 
Lets say that in addition to these three shots you would also like to include shots 123460 
and 123461.  You would then click the button “Add additional Shots” and put 123460 as 
the first shot number at 123461.  At this point if you were to click the button “View List” 
you would see that your shot file contains the following shots: 
 
123456 
123457 
123458 
123460 
123461 



 
If you also want to include shots 123470 and shots 123480-123485 you would then click 
“Add additional Shots” and this time enter only a starting shot number, 123470.  Then 
click the “Add additional Shots” button one final time and enter 123480 and 123485.  At 
any time you can click the “Clear shots in the list” button to remove all shots from the list 
and start again.  Once you are satisfied with your list, you would click the “Done” button 
which would result in your setting shots 123456-1234458, 123460-123461, 123470, 
123480-123485 as the current shots to work with.  The file you just created will appear as 
the chosen shot file in the “Shot Lists” drop down on the main XCspectro window.  
When you begin your analysis your dataset will contain all the data accumulated over all 
the chosen shots.   
 
Viewing your Data 
 
To view your data choose “View Raw” from the “Data” menu.  At this point the 
application will go looking for your input files or for your data as you specified and it is 
at this point that your data files will be read for the first time.  This is a necessary first 
step to completing your analysis.  Choosing “View Raw” from the “Data” menu will 
bring up a new window with plots in 3 tabbed sections.  The exact appearance of this 
window and the number of plots displayed depends on the binning parameters that are set 
on the main window.  For this reason I will address the binning parameters here.  
 
Binning your Dataset  
 
On the main window there are three fields labeled “Time Bin”, “Y Bin”, and “X Bin”.  
These are the binning parameters.  The Time Bin field expects values of starting time, 
ending time, and # of points in each bin with all values entered in milliseconds.  If you 
forget how to enter the values, you can click on the “Time Bin” button and a messagebox 
will appear that will remind you.  For example, you could enter the following: 
 
1000, 6000, 5000 
 
This entry would indicate that binning should start at 1 second and go through 6 seconds 
with 5 seconds in each bin, or just one bin.  Another possibility would be: 
 
0, 8000, 2000 
 
This entry would indicate that binning should start at time zero, go through 8 seconds 
with 2 seconds in each bin for a total of 4 bins.  This would result in 4 plots on the Time 
tab of your “View Raw” window.   
 
The “Y Bin” and “X Bin” fields expect entries in the form of starting channel #, ending 
channel #, and number of final bins.  If you forget how to enter the values, you can click 
on the “Y Bin” or the “X Bin” button and a messagebox will appear that will remind you. 
.For example, if you entered the following in the “Y Bin” field: 
 



200, 1600, 4 
 
This entry would indicate that binning should begin at channel 200, go through channel 
1600 and bin those channels 200-1600 into 4 groups.  Likewise for the “X Bin” field.  If 
you entered the following: 
 
0, 2600, 512 
 
This entry would indicate that binning should occur between channels 0 and 2600 and the 
final resolution should be 512, or 512 final groups/values.  
 
So if we had the following binning parameters: 
 
“Time Bin” 1000, 6000, 2500 (2 bins) 
“Y Bin” 200, 1600, 4  (4 bins) 
“X Bin” 0, 4096, 512  (512 bins) 
 
We might see returned the following “View Raw” window: 
 
  

 
 
 
The first tab/column of plots shows various representations of the raw data.  The first plot 
is a histogram by channel number of all the raw counts.  By default the 2nd plot remains 



empty.  The 3rd plot shows the data collapsed over the x-channels and bins counts in the y 
direction.  The 4th shows the number of counts in each time bin.  The second tab is the 
“Time Groups” tab and shows two time bins/groups, labeled 0 and 1, with time 
increasing from top to bottom (1 being later in time).  The last tab is the “Y Groups” tab
and shows four time bins/groups, labeled 0-3, with channel number increasing fr
bottom to the top as it appears in the “Accumulated Data” raw plot (group 3 displaying 
the highest channel numbers).  Each of the plots displayed in this window have a ‘contex
sensitive menu’ that can be brought up by right clicking on the plot.  If you right click 
(click on a plot using the right-most mouse key) you will see a small menu appear with 
the following options: 
 
Save – Saves a postscri

 
om the 

t 

pt version of the plot to your Output directory as defined in the 
default_settings.dat file 

Sav le in your output directory the numerical values used to 

Any  to the save, zoom, or save text functions will be named according to 
e shots used for the fit and the name of the plot saved.  So for example,  If you were 

 
xt.  

  After modifying the bin parameters on the main window as 
escribed above, click the “Rebin” button.  This will cause the data to be re-binned 

nel parameter listed in the crystal.dat file is 
ependent on the number of x-channels chosen by your binning parameters.  If you do 

et after 

iewing your Data – Part II 

ehavior is that the 2nd plot on the “View Raw” window is 
ft empty.  This plot has two optional functions.   

dition view of raw data.  It is achieved 
y choosing “View Raw Calib” from the “Data” menu instead of “View Raw”.  Doing so 

 

Zoom – Brings up a larger version of the plot/tab.   
e text – Saves to a text fi
create the plot 

 
 files saved due

th
using shot number 7011 and you saved the top left plot a file would appear in your output
directory named raw_7011.ps  The text version of the file would be named raw_8099.t
Postscript files can be read by any postscript viewing program such as ghostview and can 
also be converted to pdf.   
 
Bin values can be changed.
d
according to the new parameters and will cause a new “View Raw” window to open 
displaying your newly binned data.   
 
IMPORTANT NOTE:  The mm/chan
d
not get a good fit a likely culprit is the mm/ch parameter which may need to be res
having binned your data. 
 
 
V
 
As stated above, the default b
le
 
The first possible use of the second plot is for an ad
b
results in a 2nd plot that shows “Raw Total Accumulated” data with the y-dimension 
collapsed, counts per x channel.  The 2nd use of this plot is for displaying de-curving 
information as described below.   



De-Curving 
 
Since the detector makes use of a spherical crystal data is typically curved in the y 

r this reason, the W line in 1 Y bin/group may not fall into the same x 
hannel as that of another bin as you traverse the Y dimension of the detector.  A 

w 
 the 

n to 

in 

 

he curve 

 
f it is selected before choosing “View Raw” from 

e “Data” menu, data will automatically be de-curved at the time of initial binning.   

e you are satisfied with the binning selections you have made for you data, you can 
our analysis.  At the bottom of the “View Raw” 

indow you will notice too fields labeled “T Groups” and “Groups”.  Here you can enter 

 

forget the format accepted by these fields you can click on the buttons labeled “T 
oups” and “Y Groups” for a reminder.  If you do not enter anything in these fields all 

roups binned will be used in your analysis.   

ypically the x-ray crystal analysis is completed by a series of fits varying different 
r different regions.  A typical starting point is to fit first over the W-

ne region.  For this reason it is often necessary to set the channel limits over which to do 

direction.  Fo
c
“Decurve” feature has been added for this reason.  Once you have displayed your ra
data, you can de-curve by first selecting the “Decurve Y/N” button and then clicking
“Decurve” button on the main window.  The de-curve feature uses cross-correlatio
find the W and Z lines in each of the bins specified and then shifts them to make them 
line up with each other.  The bins used for the cross-correlation are not the same as those 
used to display/analyze the data.  The cross-correlation parameters can be set on the ma
window in the section labeled “Decurving Cross-Correlation Parameters:”  “X 
resolution“ and “Y resolution”.  By default these values are set to 2048 and 64 but the can
be changed.  Once you have clicked the “Decurve” button the “View Raw” window will 
update with a straightened raw data set and the 2nd plot will then be filled with t
used to straighten the data-set.   
 
IMPORTANT NOTE:  The “Decurve Y/N” selection determines whether the application
straightens your data-set by default.  I
th
.     
Selecting Bins/Groups for Analysis 
 
Onc
chose specific groups/bins to use in y
w
the number/s of the groups you wish to use in your analysis.  The group numbers can be 
entered like: 
 
0,1 
1-3,5 
2
 
If you 
Gr
g
 
 
Setting Fit Limits 
 
T
parameters and ove
li
a fit.  It is possible to select the time and Y groups desired for this selection.  This is 
useful mainly for the case of data that has not been de-curved or if there is a particular 
bin/group that has very poor statistics that may throw off your channel selections.  You 



can select the groups you wish to include by following the instructions above in the 
section entitled “Selecting Bins/Groups for Analysis”.  Once you have selected the 
groups you wish to use, there are two ways you can set your fit limits.  The first method,
you know what channels you wish to use, you can set them on the main program win
in the fields labeled “Limit(chan):Bkgnd”,”Fit”,”WLine”,”Display”.  The Bkgnd ch
limits are those over which you want to fit the background.  The “Fit” channel limits are 
the channels over which you want to complete the fit, which initially is often smaller than 
the total number of x channels after binning.  The “W Line” channel limits are those 
channels where the W line lies.  Alternatively, these channels can be selected graphically 
by choosing “Set Limits” from the “Data” menu.  Doing so will result in data from the 
chosen time and Y groups to be collapsed and the displayed in the following window:
 

 f 
dow 

annel 

 

 
 
 
The “Set Channel Limits” window allows you to select graphically your channel limits.  

s you move your mouse over the plot, you will notice that the “Pixel #” and “Count” 
ields update with the current value over which the mouse moves on the plot.  For a better 

A
f
view, you can change the channel limits on the plot by entering channel numbers in the 
“Change Display Chan min, max” field.  For example, above you can see the channel 
limits have been set to 100,500.  This is only used to help select your fit channel limits.  



The “BRANGE” is the background channel limits.  You can set the background limits by
entering the channel numbers in the fields after the “BRANGE” heading.  Alternatively
you can click on the “BRANGE” button and then click on the plot to select first a starting
and then again to select an ending channel.  Likewise for the “WRANGE” or W line 
limit, “FRANGE” or fit limits, and “DRANGE” or display limits.  For example, above 
the limits for each are set to reasonable values for the first fit.  Once you are satisfied 
with your limits, click the “I’m Done” button to close the “Set Channel Limits” windo
You will notice that channel limit fields on the main window will update with the values
you have chosen.   
 
 
IMPORTANT NOT

 
, 

 

w.  
 

E:  The “Set Channel Limits” window is a blocking window.  The 
st of the application will not respond until this window has been closed by clicking the 

I’m Done” button. 

he lines included in the fit are set on the section of the main window labeled “Fit 
lude the lines: 

4 satellites 
 satellites 

selected on the main window are the ones that will be included in the fit.  
 a toggle button so you can add or remove lines from your fit by clicking 

n the line you wish to add or remove.   

he fit parameters are listed at the bottom of main application window, along with their 
fit, 0 if no fit has been yet executed.  The values 

ssigned to each parameter before a fit is executed come from the vars.dat file.   

re 
t are 

hose 
le 

 

re
“
 
Selecting Lines to Include in your Fit 
 
T
Lines”.  Typically, a first fit would inc
 
W 
W3 satellites 
W
W5
W6 satellites 
 
Lines that are 
Each button is
o
 
Selecting Parameters to Vary in your Fit 
 
T
current value and the sigma from the last 
a
The default or starting values for the fit can be modified in this file, as well as the 
maximum allowed and minimum values allowed.  Fits whose results return values 
outside of these min-max values will not be used.  Also in the vars.dat file there a
optional correction factor that can be applied to any of the variables.  Variables tha
selected on the main program window are those that will be varied on the next fit.  T
that are not selected will be held constant during the fit.  Again these buttons are togg
buttons, so variables can be changed to be varied or held constant by clicking on them.  A
typical first fit would vary the parameters: 
 
LO 
WA 



BG 

 keep all the rest fixed.   

xecuting a Fit 

nce you have binned your data, set the limits of your fit, chosen the lines to include in 
rameters to vary in your fit, you are now ready to execute a fit.  A fit can 

e executed by selecting “Analyze” from the “Data” menu.  .  The application will 

ow 

d 

tarting a New Fit 

n the main window you will see a button labeled “New Fit”.  Clicking this button will 
meters to return to default values and clear the raw data to allow a 

ew dataset to be read in.  After clicking the “New Fit” button you  will need to re-enter a 

xample Steps for completing Data Analysis 

 this section will attempt to cover the basic steps required to complete analysis on a set 
iscussed in detail in the sections above, 

ut here I have tried to outline the basic steps involved in completing analysis on a data 

TI 
TE 
 
And
 
 
 
 
 
 
E
 
O
the fit and the pa
b
complete a least squares fit for each Time and Y group selected on the “View Raw” 
window, comparing each spectra to a synthetic spectra constructed by the theoretical 
predictions of Vainshtein and Safranova, Dubau and Gu.  The values of the parameters 
that were varied in the fit will update on the main application window as well as the 
sigma values from the fit.  The results of each fit are then displayed in a separate wind
 
If you are unsatisfied with the results of the last fit and want to change a parameter an
repeat it, you can do so by choosing “Undo Last Fit” from the last.   
 
 
 
 
 
S
 
O
cause all the fit para
n
shot number in any of the ways described above in order to continue. 
 
 
 
E
 
In
of  Xray Crystal Data.  All of these functions are d
b
set.  As you will see later, in the section entitled “Scripting”, it can be very useful to keep 
track of the steps you are taking to complete your analysis if you will want to do the same 



steps for other data sets.  For this reason, it is a good idea to keep note of the binning, 
values, groups, channel limits etc. that you use for your analysis as you are doing it.   
 

1) Edit the setup files. 
 

 

l Name parameter reflects the crystal used to create your 
ata. (If it does not you can find or add the correct crystal parameters in the 

rystal.dat file is dependent on the x dimension binning that you choose.  The 
W 

 

 

 your data is located in files: 
odify the Data_Dir parameter to reflect the location of your data files. 

e absolute or relative, but be sure that they exist!  
is 

8099.SIK  

uld  contain: 

otfile_prefix  XCS000 
otfile_suffix  .SIK 

plit data set where the full data set is split 
orizontally, having a top and a bottom then you will want to use the 

hich file 
s made up 

0008099_1.SIK (containing the top) 
CS0008099_2.SIK (containing the bottom) 

Default_settings.dat 
 
Verify that the Crysta
d
crystal.dat file and change the Crystal Name parameter in this file to match) 
 
IMPORTANT NOTE:  The millimeters/channel (mm/ch) parameter in the 
c
mm/ch are calculated by comparing the distance on the detector between the 
and Z lines with the number or channels measured between the W and Z lines. 
The number of channels between the W and Z lines is dependent on the number 
of bins/resolution of your data, which is set by the X Bin value on the main XC 
Spectro window.  Therefore, if you change your x binning, you will need to 
modfy the mm/ch parameter in the crystal.dat file for the crystal you are using to
reflect your change.   
 
 
If
M
Paths for input and output can b
Verify the settings in the datafile.dat file. As an example if your data file 
named: 
 
XCS000
 
Then datafile.dat sho
 
 
sh
sh
 
If your data file is one of a s
h
read_sik_split_xyt as your read_program and you will need to specify w
contains the top and which contains the bottom.  So if your dataset wa
of  
 
XCS
X
 



Then you would have the prefix and suffix as above and you would have the 

p    _1 

gram read_sik_split_xyt 

arameters such as top and bottom are for data sets that are made up of two files 

 your data is located in mds: 
r to mds.dat 

e names where your data resides. 

odify the Output_Dir  parameter to reflect the location where you would like to 

nalysis.dat  
 

Verify that the timebase is set correctly for your data set.  The timebase should 

 
at the tmin and tmax values are set correctly (values are entere”d in 

 
2) Using the interface 

Selecting Shots to use 

he application allows several methods for selecting shots.  The simplest is that 
e 

lternatively if you wish to gain better statistics by combining data from more 
 
 

S0008102.SIK 
 

parameters 
 
to
bottom  _2 
read_pro
 
P
each representing one half of the total data set.  In this case you would use the 
read_sik_split_xyt (or your own idl function) to read your data.   
 
If
Change the Data File paramete
Modify the mds.dat file to reflect the tag/nod
 
M
put the results of your analysis files, i.e. output plots etc. (don’t forget to create 
this directory if it does not already exist – on unix this is done by typing mkdir 
<dirname> at the command line) 
 
A

reflect the conversion of your data timestamps into seconds.   
 
Verify th
seconds). 

 

 
T
you can select a single shot and enter its number into the first box on the interfac
folllowing the heading “Shot Range” on the GUI and then pressing ENTER.   
 
A
than one shot you can either enter a 2nd shot number in the 2nd box following the
heading “Shot Range” on the GUI and press ENTER.   As a final option, you can
use the “Generate Shot List” feature.  If you chose the former, the application will 
assume you want to use every shot from the first entered through the 2nd entered.  
So for example, and continuing with the example of the naming convention prefix 
and suffix described above, if you put the number 8099 in the first box and the 
number 8102 in the 2nd box XCspectro will attempt to find files 
XCS0008099.SIK, XCS0008100.SIK, XCS0008101.SIK and XC
in the directory you specified in the default_settings file.  If any one of these files



is missing or unreadable this will result in an error.  XCspectro will then combine 
the data of all 4 shot files for analysis.   
 
If for example you do not have data for shot 8101 but you want to combine data 

 

 
3) Viewing your data 

The next step would be to view your raw data.  This would be done by choosing 

 
4) Binning 

At this point you would be able to determine how you want your data to be binned 

e “T 

5) etting Fit Limits 
the channel limits for your fit.by choosing “Set Limits” from 

t, 

ch the 

6) nalysis 
select the Fit Lines you wish to be included in your fit and the variables 

p 5.  

 

from more than one shot then you will most likely use the “Generate Shot List” 
feature.  This feature can be invoked by choosing  “Generate Shot List” from the
“Data” menu on the GUI.  See the section “Generating Shot Lists” for more 
information on this feature.  

 

“View Raw” from the “Data” menu on the main window.   

 

and which time and y slices of your data you want to analyze.  The Binning 
parameters are set on the main XCspectro window under the headings “Time 
Bin”, “Y Bin”, and “X Bin”.  Once you are satisfied with your bins, you can 
select specific Time and/or Y groups to analyze or use them all. To select a 
specific time region/s put the Time group number/s that you wish to use in th
Group” field at the bottom of the “View Raw” window.   You can enter groups 
like 0-1,3.  This is also true for the Y groups.   
 
S
Next you must set 
the “Data” menu.  Set the channel ranges limits for the W line, the background fi
the whole area to fit and the area to display.  Typically more than one fit is used to 
fit your data and initial fits use a smaller subset of the total spectra.  After 
completing a fit you can repeat this process to expand the channels over wi
fit will be done.  You can also do this by editing the fields for the limits on the 
main XCspectro window.   
 
A
You must 
you wish to fit on the main XCspectro window by clicking the things you wish to 
include/vary and deselecting those you wish to exclude or keep constant.  Then 
choose “Analyze” from the “Data” menu.  This will return the values of the 
parameters varied in the fit and a plot of the fit over the ranges selected in ste
This step can be repeated as many times as necessary.  Fits can also be “undone” 
by choosing “Undo Last Fit” from the “Data” menu. 

 
 
 



Scripting 

C Spectro allows the user to set the program up for unattended execution or for quicker 

s 

L>@xc_script 

 your file is named xc_script.pro 

he following is a list of command with a comment on their use: 

->SetCrystal, "EAST"  ; Set the active crystal to the one named 

a->SetShots,file='east_shots.shot'    analysis 

hot1=7315  
 2 

a->set_xyt,[1000,6000,5000],'t'  to 6 seconds in 1 

a->set_xyt, [200,1600,4],'y'   00-1600 into 4 groups 

 
->viewraw :Read input data and open the “View Raw” 

a->set_ygrps, [0,1,2,3,4] nalysis 
 groups are 

a->setBLimits,88,126 its from channel 

a->setFLimits,81,197 limits from channel 81-197 
7  

48 
;and Y res 128 

 
X
execution of repetitive steps.  For this reason it’s a good idea to keep track of the settings 
and values for each of the parameters you set up so that once you have the fit exactly as 
you desire you can repeat the exact steps.  XC Spetro has built in functionality that allow
you to save a series of commands in a file and execute them as a batch.  Each of the steps 
described above can be executed from a script.  There is a command that can be put into a 
file that corresponds to setting values for the Time binning and another that will allow 
choosing bins to use for your analysis.  An example script is contained in the file 
xc_script.pro which can be run by choosing “Execute Script” from the “Data” menu and 
then navigating to your script with the file dialog box that will open.  Scripts can also be 
run from the IDL command line if interactive IDL is available/licensed as follows:.   
 
ID
 
 
If
 
T
 
a

;EAST in the crystal.dat file 
;set a shot file for use in your

a->SetShots, shot0=7311  ;set a single shot for use number 7011 
a->SetShots, shot0=7311, s  ;Set shots in range 7311-7315 for use 
a->set_xyt,[1000,6000,2500],'t'  ; sets time bin 1 second to 6 seconds in

;groups of 2.5 seconds 
 ; sets time bin 1 second
;group of 5 seconds 
;sets y bin channels 2

a->set_xyt,[0,2600,512],'x'  ; sets x bin channels 0 - 2600 binned into 
;512 points 

a
;window  
;Set y groups 0-4 for a

a->set_tgrps, 1 ;Set T group 1 for analysis (all
;zero based) 
;Set background fitting lim
;88 to 126 
;Set fitting 

a->setWLimits,137,15 ;Set W line limits from channel 137-157
a->setDLimits,36,473 ;Set display limits from channel 36-473 
a->decurve,1,2048,64 ;Execute Decurve function with X res 20



 
 ;Vary Ti a->SetVars,'TI',1 

->SetVars,'TE',1  ;Vary Ti 

fit 

->SetFLimits,58,269 
->SetDLimits, 39,349 

  ;Include the line X in the fit 
->SetLines,'Y',1     ;Include the line y in the fit 

 it 
 fit 

 t 
t 

 this way all the functionality of the application can be utilized from a script.  

s a final note, the XC Spectro program is also possibly extensible to other kinds of 
ectral analysis.  The binning, input reading, and fitting routines used are all named in 

a
 
a->Analyze ;Execute a 
 
 
a
a
 
a->SetLines,'X',1   
a
a->SetLines,'Z',1     ; Include the line z in the fit 
a->SetLines,'W2',1     ; Include the line W2 in the fit 
a->SetLines,'Q',1     ;Include the line  Q in the fit 
a->SetLines,'R',1    ;Include the line  R in the fit 
a->SetLines,'S',1     ;Include the line  S in the fit 
a->SetLines,'T',1     ;Include the line  T in the fit 
a->SetVars,'LO',0    ;Fix the parameter Lo in the f
a->SetVars,'WA',0    ;Fix the parameter Wa in the 
a->SetVars,'TI',0     ;Fix the parameter Ti in the fit 
a->SetVars,'TE',0     ;Fix the parameter Te in the fit 
a->SetVars,'XA',1    ;Vary the parameter Xa in the fi
a->SetVars,'YA',1     ;Vary the parameter Ya in the fi
a->SetVars,'LI',1     ;Vary the parameter Li in the fit 
a->SetVars,'ZA',1     ;Vary the parameter Za in the fit 
a->Analyze     ;Execute another fit 
 
 
 
In
 
 
A
sp
input files and can be replaced by other routines if so desired.  Additionally the user 
interface itself reads the names and values of the parameters to fit from intput files.  
Replacing those files with others would allow the interface to display and fit a completely 
different kind of data.  
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